can we write a 2gb eMMC debian Image on 4gb eMMC beagle bone rev c

I am trying to flash the 4 gb eMMC with a 2GB eMMC flasher image. As i require more space on the eMMC to load the dependencies of my hardware. while flashing a 4 Gb image the image it self acquired 1.9 gb of the total eMMC space. Now when i am trying to flash a 2gb eMMC flasher image the LEDs are continuously running . at first i thought its a part of flashing but even after 15 mins the condition is same.

Q. Will a 2GB eMMC image work on a 4GB eMMC beagle bone black ?
Q.Is this behaviour Normal. If not then is the problem of image i am trying tgo flash or something else, The image i am flashing is BBB-eMMC-flasher-debian-7.5-2014-05-14-2gb (2).img.xz?
Q. if the flashing is done can i expand the space in the eMMC to 4GB and image still be the same ?

That is a very old version you are flashing. Is there a reason for using it ?

In theory there should be no problem as long as long as the image you are flashing is less than the destination size.

You would need to mount the sd-card image and see what the flasher script is trying to do to be sure though.

You might be better off using the latest minimal version.

1 Like

i searched for a AM335x debian minimal eMMC Flasher Image but was not able to find a suitable one i tried getting some images which seems to be latest but they were unstable i guess these specifications are a bit outdated that’s why no stable images are available. i need mare space on eMMC in order to not have SD installed on it after update and upgrade only 1.2 gb of space is left on the eMMC.

Can you please provide some link to the 2gb minimal eMMC latest image which is stable ?

This is the current memory status of eMMC
debian@beaglebone:~$ df -h
Filesystem Size Used Avail Use% Mounted on
udev 215M 0 215M 0% /dev
tmpfs 49M 2.2M 47M 5% /run
/dev/mmcblk1p1 3.5G 2.1G 1.2G 64% /
tmpfs 242M 0 242M 0% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 242M 0 242M 0% /sys/fs/cgroup
tmpfs 49M 0 49M 0% /run/user/1000

You could try these

Debian Bullseye.

Not sure how small it actually is though, and depending on your needs you may need to install other packages.

the Image you provided does not boot, even the Balena Etcher shows this message

No eMMC blinks when trying to boot the image from the SD card. thus this image is not stable/bootable, I guess i had tried this image earlier too but the same result was received.

there is a checksum to go with the image

try downloading and checking it.

I assume you are unzipping the image file after downloading it, or does Balena Etcher do that automatically ?

I am just downloading the image file to try it, will post back in a few minutes

yup fails for me also.

@RobertCNelson Is there an issue with the flasher images. The sizes for BBB are very small and won’t boot when flashed


Ok the non flasher images work fine.

IF you download

You can flash it to an sd card.

You can then boot to check if you want.

To turn it into a flasher, you can mount the sd-card image and edit /boot/uEnv.txt
Scroll to the bottom of the file and un comment the line, by removing the #


This will then flash the eMMC when it boots. If you have a serial console you can see the progress. It should power down when finished.

I have just flashed this to my BBB. The root file system uses about 918M, before installing anything.

I am not sure if my BBB is one of the older ones with only 2G of eMMC or perhaps the filesystem has not been expanded automatically. There should be some instuctions somewhere to do this

1 Like

Thanks @benedict.hewson it worked well for me to now i have 2.5 gb space on eMMC.

doh! i see what caused the corrupt (small) files, rebuilding! (2023-03-10)