cannot boot latest RCN image from 2016-09-28 on BBGW

Trying to test the latest RCN image from 2016-09-28. But I get a kernel panic before the flashing begins. Serial debug console shows these errors:

Begin: Running /scripts/local-premount … done.
Begin: Will now check root file system … fsck from util-linux 2.25.2
fsck: error 2 (No such file or directory) while executing fsck.ext4 for /dev/mmcblk1p1
fsck exited with status code 8
Warning: File system check failed but did not detect errors
[ 9.628045] EXT4-fs (mmcblk1p1): mounted filesystem with ordered data mode. Opts: (null)
Target filesystem doesn’t have requested /opt/scripts/tools/eMMC/
Begin: Running /scripts/local-bottom … done.
Begin: Running /scripts/init-bottom … done.
switch_root: can’t execute ‘/bin/sh’: No such file or directory
[ 9.758682] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100

…insert kernel dump here…

At this point everything hangs. Anyone else seeing the same thing? Build used is this one:


Just double checked ^... seems to be working correctly...

[ 3.483814] remoteproc0: powering up wkup_m3
[ 3.488330] remoteproc0: Booting fw image am335x-pm-firmware.elf,
size 217148
[ 3.495902] remoteproc0: remote processor wkup_m3 is now up
[ 3.501611] wkup_m3_ipc 44e11324.wkup_m3_ipc: CM3 Firmware Version = 0x192
[ 3.514132] bone_capemgr bone_capemgr: Baseboard:

you are using a good quality power supply ?

Nevermind. I tried several images over the past 2 months, and they were all failing the same way. I completely shut down my desktop, rebooted it, re-wrote the latest image to my uSD card, and now it is all working again. Latest image is up and running on my BBGW. Lost half my evening to this issue. I don’t know why/how Linux sometimes seems to lose its shit when writing images, and when it happens, a complete reboot seems to be the only thing to fix it.

Sorry for the false alarm.


Have you tried instead of dd?

Just tried it. Definitely more friendly than dd. Thanks for the