cannot connect reliably connect to my BBB from my Ubuntu laptop via USB


I’ve got a BBB. I’m working on an Ubuntu laptop. BBB’s eMMC has unknown config, but SD card has Angstrom installed. I’m having issues connecting to the board via USB. It works 20% of the time. I tried with and without the udev rules (73-beaglebone.rules), I tried with with or without the ftdi_sio module loaded… I can’t get a consistent result. Possibly, my USB cable is not reliable… I’ll try to test with another one. I also tried with DC power supply in case my USB could not deliver enough power but it didn’t help.

The udev rules for BBB identify it from ID 0403:a6d0, but lsusb tells me that “1bcf:2885 Sunplus Innovation Technology Inc” is connected, and in case the connection is successful “1d6b:0104 Linux Foundation Multifunction Composite Gadget”. But not 0403:a6d0. So it seems the udev rules won’t be of any help… Can anyone explain the udev rules? I know the first one is to load the ftdi_sio module when the 0403:a6d0 device is connected, but I don’t understand the other rules.

Also, is there an error with the 0403:a6d0 ID? or is there something else going on here?


I believe the 0403:a6d0 id is for the original Beaglebone with its built in serial to USB adapter. The Beaglebone black requires an external TTL serial to USB converter. The recommended FTDI cable has the id 0403:6001. These ids are used to identify the console serial port connection to the board.

The 1d6b:0104 id is for the BBB combination device that supports RNDIS ethernet over USB and USB mass storage. It identifies the connection to the miniUSB connector on the BBB.

Dennis Cote