Cannot connect to

I have been playing around with the BeagleBone Green for a project that I am working on. About 3 days ago, my BBG suddenly lost the ability to connect to the static IP address “”. I simply left the BBG connect to my laptop and went to lunch, and after I came back from lunch the connection stopped working forever.

Since this bug occured, I have been using local network to access the BBG (beaglebone.local), but it is not desirable since I need to plug in wifi or ethernet every time I wish to connect. The other method that worked for me is connect through a FTDI cable, but this is also troublesome because the cable takes up a lot of space.

At this point I have two theories why the board is no longer connecting to First, I might have messed up the network/interfaces file when I was trying to set up wifi. There doesn’t seem to be anything wrong when I checked this file but I could be wrong. Second, my laptop going to sleep while the BBG was still connected might have messed up something in the board.

I would greatly appreciate any opinions/solutions.

Typically, things start failing after changing something.
What changes did you make in which scripts?
Is exposed via the USB?
If you check your network interfaces (e.g. ifconfig) does it still list the usb interfaces?

Yes, is exposed via the USB. The IP address is listed under usb0 when I run ifconfig.

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::7a04:73ff:fea9:1e65 prefixlen 64 scopeid 0x20
ether 78:04:73:a9:1e:65 txqueuelen 1000 (Ethernet)
RX packets 27070 bytes 8707292 (8.3 MiB)
RX errors 0 dropped 24 overruns 0 frame 0
TX packets 14300 bytes 3984042 (3.7 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

I changed etc/network/interfaces while trying to get wifi but has since changed it back to the original file.

The loopback network interface

auto lo
iface lo inet loopback

WiFi Example

auto wlan0
iface wlan0 inet dhcp

wpa-ssid “”

wpa-psk “”

Ethernet/RNDIS gadget (g_ether)

Used by: /opt/scripts/boot/

iface usb0 inet static

Do you still see the ethernet interface provided by the BBG on your laptop when you plug in the BBG?
If not then you might want to check the USB gadget configuration in /sys/kernel/config/usb_gadget/.
There should be a subfolder which contains a file USB which is not empty.
Additionally, in the functions subfolder there should be an rndis.* folder.

I actually expect the USB gadgets to be configured correctly since you see the usb0 in your ifconfig.

Interestingly for me beaglebone.local resolves to when I use my Beaglebon Black (BBB).
I also have two network interfaces that are provided by my BBB.
The second one is configured for

Could you also check that in the meantime there is no other host on your network that is using
If that is the case then you might have a routing issue.

How did you find out it is no longer working?
Did SSH stop working?
Did you try to ping it?

I found same issue can’t access i use BBG same.
I dev on Ubuntu 18.04 and open browser on Firefox and Google chrome

i can try to use ssh and ping but can’t access webserver
Can i check this server are down ?
or I take any mistake
เมื่อ วันอาทิตย์ที่ 19 มกราคม ค.ศ. 2020 0 นาฬิกา 08 นาที 00 วินาที UTC+7, Hugo van den Brand เขียนว่า:

I found same problem can’t access to but I can ping and ssh
I use BBG on Ubuntu18.04
Can I check webserver are down

เมื่อ วันอาทิตย์ที่ 19 มกราคม ค.ศ. 2020 0 นาฬิกา 08 นาที 00 วินาที UTC+7, Hugo van den Brand เขียนว่า: