Cannot connect to Beagle Board rev B4


I have a Beagle Board revision B4 and I'm unable to connect to the
serial console. I'm using the AT/Everex cable adaptor connected to a
NULL Modem serial cable to my computer's COM1 (or /dev/ttyS0 on Linux)
input port.

On different host computers, I tried different terminal software.
Minicom on Ubuntu and Hyperterminal on Windows. Everytime my settings
were set to 115200 8N1 with no flow control.

Next, as described in the various procedures, I'm turning on the
Beagle Board by connecting the USB cable and nothing appears in the
terminal window. I tried with clicking the user button or not while
turning it on. I also try to start the terminal window before and
after the power on of the device. Every time I get only the PWR-D5 led
on and nothing else.

If no serial cable is connected, the board seems to power up correctly
cause all the leds (4) are turning on after a couple of seconds and
also I can see the Beagle Board logo on my HDMI monitor.

Is there any specifics issues with rev B4 or something else that was
not mentioned in the procedures? Something else I should try?


This is a VERY old board. There were issues on this version of the board with the level translators going bad on the serial port. You could have this issue. You can also check and make sure that you have the ribbon cable connected correctly where the red stripe goes to pin 1 on the connector.


Thanks for the hint but the ribbon cable is connected correctly.
Actually I did try it the other way around without success. If someone
could point me out to more information about the problems with the
serial port on rev B4 I would appreciate it.

The U9 goes bad and has to be replaced. It is documented in the System Reference Manual.


The U9 part is probably my problem because I can actually see that it
is burned. Is this part related to the serial connection only? Is
there any thing I can do with the USB (USB-serial connection)? This
Beagle Board was never used before so nothing was previously flashed
on it.


I suggest that you request an RMA and see if they are willing to repair it for you.