Cannot connect to PocketBeagle

Hi,

Following the setup instructions online, PocketBeagle does not show up when I connect it to my Mac Mini (macOS Big Sur). There’s no network adapter with an IP in either the 6.x or 7.x range. What can I try next?

Thanks

Please try:

https://rcn-ee.net/rootfs/bb.org/testing/2020-11-30/buster-iot/bone-debian-10.6-iot-armhf-2020-11-30-4gb.img.xz

Big Sur nuked our default gadget module, we switched mid 2020, so
above should work, please help us confirm it works now..

Regards,

I had the same problem, and this image works for me! Thank you! Phew, this was the only reference I found on the internet referencing this issue with macOS Big Sur.

For anyone else coming here from the wider internet who is wary of downloading the above image, the latest “testing” image here
https://elinux.org/Beagleboard:Latest-images-testing
also worked for me. More specifically, the “Debian 10 (Buster) IoT (AM335x based BeagleBone’s and PocketBeagle) (Target Media = microSD)” image here
https://rcn-ee.com/rootfs/bb.org/testing/2020-08-25/buster-iot/bone-debian-10.5-iot-armhf-2020-08-25-4gb.img.xz
works with my new BeagleBoard Green (it’s nearly identical to a BeagleBoard Black) and macOS Big Sur. It’s from the same Robert Nelson website as the image URL above, and it seems like Robert Nelson (a BeagleBoard.org Foundation Board Member) is the primary engineer for building and distributing these images. I only mention his credentials because I was wary of rcn-ee.com and rcn-ee.net, since they did not have an index page and their blog page redirects to a defunct Google+ page. :slight_smile:

Robert, I’m sure there’s much testing to do on these images, but when do you expect this latest images list here
https://beagleboard.org/latest-images
(9 months old now) will be updated with images that are compatible with macOS Big Sur (2 months old now)?

Thank you again!

Thanks Jan Musi!

I had the same problem, and this image works for me! Thank you! Phew, this was the only reference I found on the internet referencing this issue with macOS Big Sur.

For anyone else coming here from the wider internet who is wary of downloading the above image, the latest "testing" image here
https://elinux.org/Beagleboard:Latest-images-testing
also worked for me. More specifically, the "Debian 10 (Buster) IoT (AM335x based BeagleBone's and PocketBeagle) (Target Media = microSD)" image here
https://rcn-ee.com/rootfs/bb.org/testing/2020-08-25/buster-iot/bone-debian-10.5-iot-armhf-2020-08-25-4gb.img.xz
works with my new BeagleBoard Green (it's nearly identical to a BeagleBoard Black) and macOS Big Sur.

Thanks for testing, I still haven't got the urge to upgrade my Mac Mini.

It's from the same Robert Nelson website as the image URL above, and
it seems like Robert Nelson (a BeagleBoard.org Foundation Board
Member) is the primary engineer for building and distributing these
images. I only mention his credentials because I was wary of
rcn-ee.com and rcn-ee.net, since they did not have an index page and
their blog page redirects to a defunct Google+ page. :slight_smile:

I see the index page as a way to hide things, I prefer to just leave
it wide open. :wink: Thanks i forgot about that old blog.html page, i
changed it to my github..

Would you be more comfortable if I signed the files? using the same
gpg key i use for the deb archive:

https://rcn-ee.net/repos/debian/conf/
http://debian.beagleboard.org/riscv64/conf/

or

apt-key adv --keyserver keyserver.ubuntu.com --recv-key D284E608A4C46402

But then you'd need to trust that key. :wink:

Robert, I'm sure there's much testing to do on these images, but when do you expect this latest images list here
https://beagleboard.org/latest-images
(9 months old now) will be updated with images that are compatible with macOS Big Sur (2 months old now)?

i know, got really busy with day job since the start of the pandemic..

Regards,

Understandable! (Regarding index.html, blog.html, and being really busy with your day job. haha)

FWIW, after getting my BeagleBone Green working with the new images, I switched to trying to get it working with the latest image for Bela (a BeagleBone Black cape for real-time audio & signal processing). I posted about those additional troubles here
https://forum.bela.io/d/1492-no-connection-to-bela-mini-on-macos-big-sur
It seems that, despite configuring its gadget-ness successfully, the latest Bela image is unable to self-assign an IP address on macOS 11.1 Big Sur.