Cannot install minicom with Jessie 8.3 lxqt

Hi,

I have installed Jessie 8.3 with lxqt onto the eMMC of a rev C board. I used this image:

[https://rcn-ee.com/rootfs/bb.org/testing/2016-01-24/lxqt-4gb/BBB-eMMC-flasher-debian-8.3-lxqt-4gb-armhf-2016-01-24-4gb.img.xz](https://rcn-ee.com/rootfs/bb.org/testing/2016-01-24/lxqt-4gb/BBB-eMMC-flasher-debian-8.3-lxqt-4gb-armhf-2016-01-24-4gb.img.xz)

The flashing seems to be fine but when I try to install minicom I get:

root@beaglebone:~# apt-get install minicom
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package minicom
root@beaglebone:~#

Any ideas what the problem is?

I am also trying to get all the UARTS working.  I have Googled long and hard but the instructions I have found are either for an earlier version of Debian or so terse I cannot follow them, such as these:

https://theunemployablekoder.wordpress.com/2015/03/28/enabling-uart1-and-uart4-on-the-beaglebone-black-and-debian-jessie/

Can anyone point me to some step by step instructions to enable all the UARTS under Jessie?

Any advice appreciated.

Hi,

I have installed Jessie 8.3 with lxqt onto the eMMC of a rev C board. I used this image:

https://rcn-ee.com/rootfs/bb.org/testing/2016-01-24/lxqt-4gb/BBB-eMMC-flasher-debian-8.3-lxqt-4gb-armhf-2016-01-24-4gb.img.xz

The flashing seems to be fine but when I try to install minicom I get:

root@beaglebone:~# apt-get install minicom
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package minicom
root@beaglebone:~#

Any ideas what the problem is?

Run

sudo apt-get update

First to refresh the package cache.

I am also trying to get all the UARTS working. I have Googled long and hard but the instructions I have found are either for an earlier version of Debian or so terse I cannot follow them, such as these:

https://theunemployablekoder.wordpress.com/2015/03/28/enabling-uart1-and-uart4-on-the-beaglebone-black-and-debian-jessie/

Can anyone point me to some step by step instructions to enable all the UARTS under Jessie.

One example is right here… Echo bb-uart1

https://github.com/beagleboard/bb.org-overlays/blob/master/readme.md

Regards,

Hello Robert,

Thanks for your reply.

I did the apt-get update and then apt-get install minicom and that worked fine, thanks.

I then tried to follow the instructions at https://github.com/beagleboard/bb.org-overlays/blob/master/readme.md

I type the following:

git clone https://github.com/beagleboard/bb.org-overlays
cd ./bb.org-overlays
dtc --version (response: Version: DTC 1.4.1-g1e75ebc9)
./dtc-overlay.sh
./install.sh
zcat /proc/config.gz | grep CONFIG_BONE_CAPEMGR (repsonse: CONFIG_BONE_CAPEMGR=y)
cd /opt/scripts/tools
git pull

The next five steps just say:

v4.1.x-ti:
v4.1.x-ti + Real Time:
v4.1.x mainline:
v4.1.x mainline + Real Time:
v4.3.x mainline:

and then a command for each one. I think this is to run a script which updates the kernel. If I type uname -r I get 4.1.15-ti-rt-r43 so I’m guessing I should run the script for “v4.1.x-ti + Real Time” (rt meaning Real Time??).

Part of the response is:

info: you are running: [4.1.15-ti-rt-r43], latest is: [4.1.15-ti-rt-r40] updating…

then the update proceeds and seems to completre OK.

The next two steps just say:

capemgr: enable/disable capes on kernel cmdline:
capemgr: enable/disable capes with slots:

I’m guessing that this is showing two different methods to enable/disable capes on the BBB. Since the lernel command line seems to need cape part numbers and I’ve no idea what these might be, I’ve tried the slots commands. I type:

cat /sys/devices/platform/bone_capemgr/slots

and I get:

0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,cape-universaln

The instructions only show entries 0 to 3. I type:

sh -c “echo ‘BB-UART1’ > /sys/devices/platform/bone_capemgr/slots”

and I get:

sh: echo: I/O error

Can you tell me what I am doing wrong?

Thanks.

I think there is a conflict you can see in the dts files for “exclusive-use”, P9.26.
Not sure, but I think this will cause the IO error message.
The dts files are in /opt/source/bb.org-overlays/src/arm.

cape-universaln:
“P9.26”,

BB-UART1:

exclusive-use =
“P9.24”, // uart1_txd
“P9.26”, // uart1_rxd

Just to preclude the obvious, you are running this either as root or via sudo, right?

-hilmar

open:

/boot/uEnv.txt

remove the "cape_universal=enable" line, reboot..

Regards,

Thank you, Robert, that worked.

I tried to do the same with the console only version of Jessie but that didn’t work, and now going back to the same setup with lxqt version I can only get UART4 and not UART1 working. I think this is a seperate issue to I will post a new question when I have investigated further.

Thanks.

With the "console"

sudo apt-get update
sudo apt-get install git-core

git clone https://github.com/beagleboard/bb.org-overlays
cd ./bb.org-overlays

./dtc-overlay.sh

./install.sh

Then it'll work..

Regards,

Hi Robert,

Thanks for the advice I will give it a try.

But I still cannot get UART1 working, only UART4. I have changed out the board for another identical one (in case I have blown up UART1 somehow) and started again with a new lxqt image. I just have a hard loop between TX and RX so this is not a baud/ framing issue. Here’s some output:

root@beaglebone:~# cat /sys/devices/platform/bone_capemgr/slots
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,BB-UART1
5: P-O-L- 1 Override Board Name,00A0,Override Manuf,BB-UART4
root@beaglebone:~#

From dmesg:

[ 1643.096707] bone_capemgr bone_capemgr: part_number ‘BB-UART1’, version ‘N/A’
[ 1643.096758] bone_capemgr bone_capemgr: slot #4: override
[ 1643.096785] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 1643.096813] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,BB-UART1’
[ 1643.108422] bone_capemgr bone_capemgr: slot #4: dtbo ‘BB-UART1-00A0.dtbo’ loaded; overlay id #0
[ 1743.389923] bone_capemgr bone_capemgr: part_number ‘BB-UART4’, version ‘N/A’
[ 1743.389975] bone_capemgr bone_capemgr: slot #5: override
[ 1743.390001] bone_capemgr bone_capemgr: Using override eeprom data at slot 5
[ 1743.390030] bone_capemgr bone_capemgr: slot #5: ‘Override Board Name,00A0,Override Manuf,BB-UART4’
[ 1743.415383] 481a8000.serial: ttyS4 at MMIO 0x481a8000 (irq = 201, base_baud = 3000000) is a 8250
[ 1743.416366] bone_capemgr bone_capemgr: slot #5: dtbo ‘BB-UART4-00A0.dtbo’ loaded; overlay id #1

Note there is no line:

481a8000.serial: ttyS4 at MMIO 0x481a8000 (irq = 201, base_baud = 3000000) is a 8250

for ttyS1. Any suggestions?

Also, what is the latest Wheezy or Angstrom version where all the UARTs work out of the box?. I could at least use that to test that the hardware is working.

Thanks.