Cannot ping Eth0 from PC on BeagleBone Black

Good Afternoon,

I am developing an application for communicating with the BBB using sockets via the onboard ethernet port.

The strange part is, my client(pc)/server(BBB) application communicated perfectly the first time I ran it, but when I rebooted the BBB, it could not establish an ethernet connection.

I tried pinging the IP given by running “ifconfig” on the BBB, but it never replied

I also tried changing to a static IP ( via this post “” but I still could not connect.

Finally, I tried this on two different BBB’s one with stock angstrom, one with the newest flash image. Neither could connect. I did not change to static IP on the stock BBB.

I can still connect to usb0, via no problem. In fact I only had a problem with this when I changed eth0 to use static ip, somehow this interfered with the IP of usb0 and would not let me ssh into the BBB

Please let me know if I am missing something, I tried rebooting many times and turning eth0 on and off, but I could never establish a connection to it since.

Thank you,

HeLLO Dmit,

I’m working on the same issue of communicating with BBB using the sockets via the etethernet cable.

I’m wondering where should I start and could you give me some suggestions?

Thanks alot!