Cannot use RT2870 Ralink Wifi USB stick on Ubuntu in Beagle Board

Hi Gianluca,

I had similar issue!! with RT2870 based Linksys WiFi Dongle.

I did not workaround much, due to lack of experience and time :wink:

Instead switched to RT73 based D-Link DWA110 .
It Worked great without any problem!! [Plug n Play]. Works in both Ad-
Hoc and Managed Mode.

Netgear WG111V3 also works in Managed Mode, but I could not bring it
up in Ad-Hoc Mode.

Btw, which version of Kernal are you using ? I had used 2.6.31.5-x5.3

I could help you with D-Link as I am working on it.
Experts could help you better with 2870 :slight_smile:

Regards
Avinash

Hi.

i did use a RT73 DLink device as well, lsusb gave me:

Bus 001 Device 042: ID 07d1:3c03 D-Link System DWL-G122 802.11g
Adapter ralink rt73

It did work really well out of the box (in ubuntu and angstrom) as
long as I turned off WPA encryption, but I am not sure wether this is
due to the hardware or other settings. Ad-Hoc worked as well.

BUT: whenever the system gets laoded, I end up with a driver crash.
This usually happens to me after ~30 minutes to a few hours. At this
stage I can unplug the device and replug or reboot the machine, but
this is not quite satisfactory. I have since ordered a few more
different WLAN devices to test since they are quite cheap.

If this is not a big concern (I am able to install packages and such)
it does work well.

Tallak

I forgot to mention that I have disabled all passwords (PSK WPA etc)
from the router.

I booted with the 2.6.32.9-x9.1 kernel, and sure enough the rt2x00 and
rt2800usb drivers were there.

Doing iwlist scanning, I initially get results of the different access
points around. However, after a short period of time I get No scan
results.

Looks like it kinda works...

Note, Some users have had better luck keeping the connection going
thru network-manager then thru the iwconfig interface..

Have the drivers been installed correctly? Is there a way to bind a
driver to wlan0 so that it shows up in lshw?

Why do I get "ADDRCONF(NETDEV_UP): wlan0: link is not ready" in dmesg,
and why does the wifi stick led switch off (in my pc, it remains on)?

Looks common:

http://www.google.com/search?hl=en&q=ADDRCONF(NETDEV_UP)%3A+wlan0%3A+link+is+not+ready

Regards,

I have a Rosewill RNX-N1 usb wifi dongle that uses the rt2870 chipset, and when I tried to use it on my laptop I got driver conflicts between the rt2x00usb and rt2870sta drivers. The card sort of works during the driver fighting, but the biggest clue to me was that every scanned wireless network in the NetworkManager applet’s list had 100% signal strength, and I couldn’t actually access the internet (or any wireless network). On my computer (running Ubuntu Karmic x86), when I blacklisted the rt2x00usb drivers with these two lines added in my /etc/modprobe.d/blacklist.conf file:

blacklist rt2800usb
blacklist rt2x00usb

After a reboot the NetworkManager applet uses the card normally, the wireless network have different signal strengths, and I can access the internet with the device. The only side effect is there seems to be more messages in dmesg, but the card works perfectly AFAICT.

So, Robert: would it be possible to build the rt2870sta driver, or would you post a guide as to how to do it? I think the source for the driver is available from Ralink’s website here:
http://www.ralinktech.com/support.php?s=2 [ click on “RT2870USB(RT2870/RT2770)” and agree to the GPLv2 license to download ]

I will try to build the staging driver today, and if I’m successful I’ll post a guide.

Thanks.
– @

Actually, one step a head of you, it's Kconfig was set correct (wasn't
built on arm) and I just enabled it with in the last couple days..
I've been fighting it too with my wifi adapters...

Use 2.6.32.11-x12

voodoo@beagle-256mb-0:~$ ls -lh
/lib/modules/2.6.32.11-x12/kernel/drivers/staging/rt2870/
total 548K
-rw-r--r-- 1 root root 544K 2010-04-02 18:20 rt2870sta.ko

You'll more then likely have to set "/etc/modprobe.d/blacklist.conf"
just like on the x86, since all the rt28xx usb drivers are built as
modules....

Regards,