Can't access Beaglebone

Recently I have been trying to run Docker in the Beaglebone. I was having trouble composing the docker so I saw in forum that I should turn off the firewall. The firewall-cmd was not available so I installed it through this website:

Then I tried to run mongoDB application using the “docker compose up” command according to:

The command was running until it suddenly the connection to the beaglebone and since then I can no longer access it through ssh.

What did I do wrong? How can I access the Beaglebone again?

I was once getting docker to work.

sudo apt install docker-io maybe was the command. I will check later and return service.

Do you have a Serial Connection? TTL to USB cable? It may help people see what is transpiring.

and that above command may be bad. It could be dockerio but I am not sure right now. I need to double check.


on a Debian/Ubuntu dev. desktop machine, sudo apt install tio.

Then, tio /dev/ttyUSB0 or tio /dev/ttyUSB0,115200.

Those last two commands can be used w/ the TTL to USB cable (3.3v only). This way, you can see the boot log. This, may be a way to see what is happening w/ your system.

Do you remember what image or kernel was on the BBB…oh. When you say beaglebone, do you mean the BeagleBone Black?


P.S. If you have access to a Win 11 desktop, you can try a COM port if it is still available but one can easily get better results from Debian/Ubuntu when using the TTL to USB cable for the boot log.



Installing w/ a known Internet connection and armhf w/ Debian 11

1. Open a terminal window.
Update the package list:
2. sudo apt update 
Install Dockerio:
3. sudo apt install docker-ce 
Once Dockerio is installed, you can start using it by running the following command:
4. docker run hello-world 

AI Generated, please use w/ caution!

Before the error, the connection was achieved through TTL to USB Cable. The beaglebone is Black. I am running the commands on a Windows 11 command prompt. I can no longer run any commands to the beaglebone because I can´t establish the connection (connection time out error).
I would like to be able to control the beaglebone once more without recurring to the last resort of flashing the Beaglebone Black.

Purely installing docker shouldn’t do this… We have docker pre-installed on the BeaglePlay/BeagleBone-AI64 images… For the classic BeagleBone Black, while we never shipped with docker pre-installed, it was something i used in testing. Using your ttl-usb adapter, (connected to j1), what is showing up on bootup?


Is there another way to connect to the Beaglebone and run python commands?

I am trying to establish the connection but it fails every time with this error:
C:\Users\joseg>ssh debian@
ssh: connect to host port 22: Connection timed out

I installed the docker with success and I was able to run the command: docker run hello-world
I tried to run the image mongoDB using a docker_compose.yml file, but it wasn’t working. One supposition was that the error was due to a beaglebone firewall. So instaled the package mentioned earlier. After a successful installation I ran the command “docker compose up” and it was after that I could no longer access the BeagleBone anymore in any computer.

Potentially installing a firewall has messed up the USB ethernet interface.

However @RobertCNelson is suggesting using a serial cable connected to the serial console on the beaglebone (J1). You can’t ssh using this, you must use some serial terminal software. You can use Putty under Windows, just select a serial connection in the options. This will connect you to a console on the BB.
Login in as normal.

Then we can figure out what is messed up.

Have you tried

Are you totally locked out or can you connect a monitor and keyboard or as @benedict.hewson

Would be the only options.

You could do an nmap to see what is and if any inbound ports are listening.

Trying doing a ping


I don’t recall the MS cli ping format but believe it is similar format.


I am not sure about MS but in Linux, ssh debian@beaglebone.local works. Also, if you use WSL2, you can use the same ssh command to get into the BBB for file usage.


I have tried both and they didn´t work…

Thank you all for your help.
I was able to connect to the beaglebone again using serial connection. However it would be great if i could get access through ssh again. What should I do?

with the USB cable connected, in the serial console can you run and paste the output from.

ip -br addr

iptables -L

Result from first command:
debian@beaglebone:~$ ip -br addr
lo UNKNOWN ::1/128
can0 DOWN
can1 DOWN
eth0 DOWN
usb0 UP fe80::9af0:7bff:fe69:7790/64
usb1 DOWN
docker0 DOWN

The command iptables -L doesn’t execute because command is not found

Ok a couple of other things to check


systemctl status sshd

Also can you ping from the BBB when the USB is connected to your Windows machine ?

On Windows can you ping ?

Also probably worth looking at the output from route on the BBB

route -n

On Windows in cmd window you can also do


route print

Thank you very much for all the help.
I was able to connect through serial connection and uninstall the firewall package. This solved the problem.