Can't boot with the new kernel, debian or ubuntu

Hi guys,

It seems that I have a boot problem for my xm rev c. I am currently using the netinstall method with several sd cards:

  1. Kingston SDHC class 4, 4GB
  2. Kingston SDHC class 10, I 1, 16 GB

On reboot, it does not pass the U-Boot SPL stage and I have to redo the mmc card.

I noticed that using the netinstall method,both beagle and beagle xm boards have the same procedure.

Best,
Ovidiu

Here is the boot sequence log:

U-Boot SPL 2015.01-00011-g2efed9f (Jan 12 2015 - 17:15:10)
SPL: Please implement spl_start_uboot() for your board
SPL: Direct Linux boot not active!
reading u-boot.img
reading u-boot.img

U-Boot 2015.01-00011-g2efed9f (Jan 12 2015 - 17:15:10), Build: jenkins-github_Bootloader-Builder-90

OMAP36XX/37XX-GP ES1.2, CPU-OPP2, L3-200MHz, Max CPU Clock 1 Ghz
OMAP3 Beagle board + LPDDR/NAND
I2C: ready
DRAM: 512 MiB
NAND: 0 MiB
MMC: OMAP SD/MMC: 0
*** Warning - readenv() failed, using default environment

Beagle xM Rev C
No EEPROM on expansion board
No EEPROM on expansion board
Die ID #2a5c00029ff80000016830c31801c025
Net: usb_ether
Error: usb_ether address not set.

Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc0 is current device
SD/MMC found on device 0
Checking for: /uEnv.txt …
Checking for: /boot/uEnv.txt …
reading /boot/uEnv.txt
246 bytes read in 5 ms (47.9 KiB/s)
Loaded environment from /boot/uEnv.txt
Checking if uname_r is set in /boot/uEnv.txt…
Running uname_boot …
loading /boot/vmlinuz-current …
reading /boot/vmlinuz-current
5194104 bytes read in 321 ms (15.4 MiB/s)
loading /boot/dtbs/current/omap3-beagle-xm.dtb …
reading /boot/dtbs/current/omap3-beagle-xm.dtb
63096 bytes read in 21 ms (2.9 MiB/s)
loading /boot/initrd.img-current …
reading /boot/initrd.img-current
26517049 bytes read in 1614 ms (15.7 MiB/s)

Installer for [utopic-armhf] is using the Video Interface
Use [–serial-mode] to force Installing over the Serial Interface

debug: [console=tty0 root=/dev/ram0 rw] …
debug: [bootz 0x82000000 0x88080000:1949e39 0x88000000] …
Kernel image @ 0x82000000 [ 0x000000 - 0x4f4178 ]

Flattened Device Tree blob at 88000000

Booting using the fdt blob at 0x88000000
Loading Ramdisk to 8e6b6000, end 8ffffe39 … OK
Using Device Tree in place at 88000000, end 88012677

Starting kernel …

Hi guys,

It seems that I have a boot problem for my xm rev c. I am currently using the netinstall method with several sd cards:

  1. Kingston SDHC class 4, 4GB
  2. Kingston SDHC class 10, I 1, 16 GB

On reboot, it does not pass the U-Boot SPL stage and I have to redo the mmc card.

So, what did you change at the partition stage of the install?