Can't connect via SSH on the BBB

I have a problem with my BeagleBone black (should be rev. A5C). I followed the instruction and flashed Debian 11.2 in a microSD. I tried to connect via SSH to the board but it refuses the password.

~ ssh debian@
debian@'s password:
Permission denied, please try again.

As the instruction says I used debian:temppwd

These are the steps I followed:

  • Downloaded am335x-debian-11.2-minimal from Debian 11.x (Bullseye) - Monthly Snapshots
  • Flashed to the microSD using balenaEtcher
  • Inserted the microSD and turned on the BBB by pressing the power button.
  • From my router, I can see the BBB and its IP, tried to connect via ssh.

Unfortunately, I can’t connect the BBB to an external monitor because I don’t have the cable. What am I doing wrong?

HI @Oghma

The password should be:


It’s been that default since forever…

Side note, on something i’ve been thinking about, would users like to see shellinabox installed, so you can just go:

http://ip_address:4200/ and login vs only ssh?


Hey @RobertCNelson,
I’m trying with temppwd but I get Permission denied, please try again