Can't enable service using systemctl: Bad message


I’ve written a service (wd.service) which I want to start at boot on my BBB (running 3.8.13-bone70). I can use systemctl to start and stop it using the commands

systemctl start wd.service

systemctl stop wd.service

and everything works exactly as planned. However, when I try and get it to load at boot using the command

systemctl enable wd.service

I get the response

‘Failed to issue method call: Bad message’

I’ve scouted asround on the internet for similar error messages and there are plenty of examples of ‘Failed to issue method call: No such file’ (which all seem to boil down to overwriting the symlinks used by systemd), but nothing referring to ‘Bad message’. It seems as though, for some reason, systemctl doesn’t understand (or won’t accept) ‘enable’ as a valid command, even though it seems that this absoltuely the standard way to get services to load at boot. I’ve tried all the simple tricks I can think of, like renaming it, putting in the explicit path to the unit file, rebooting etc but all to no avail. (Incidentally, I get exactly the same response using the ‘disable’ command). And there are only so many times you can check ‘enable’ to see if it’s spelt correctly.

So now I’m stumped. Anyone have any ideas as to what could be causing this?

Any suggestions welcome,



I believe “Bad message” means there is a syntax error

I had this problem with a service I created and it was because of a typo.

The following command might give you sone useful information:
systemctl status wd.service