Can't flash beagle bone with any debian image

I can’t flash my beaglebone black with any debian image. I wrote it on my SD card and start to flash but even after two hours nothing happens but a weird marquesine on the leds. I tried to flash it with Angstrom and it worked properly. I can’t figure out what I’m doing wrong, besides I’ve done this before and the image that I used to use isn’t flashing anymore. Is the problem on my board? I don’t know what I’m doing wrong, as I said the steps are the same as always but I can’t figure out what’s wrong

Any help will be appreciated in advance


Did you decompress it (Unzip) before you wrote it to the SD card?


Yes I did it, as I said, I’ve done this thing before but nothing like this happened. Also I’m using the same 5v adapter and the same SD card. It’s just that simply isn’t working anymore. Also, as I said, Angstrom is flashing perfectly fine.


Did you check that the card is correctly formatted when you put the image on it? would remove all the partitions on it and start all over.

Also, what do you use to write on the card? And did you try to download again the Debian images? I tried with the Debian on the official BB site, and it flash my device without problems

Tried on another beagle bone black that someone lend me and seems to be the images and SD card are perfectly fine. Could it be posible that SD reader is damaged? Can’t see why but if is this, can it be replaced?