Can't get into BeagleBone Black's SSH via my Mac

I have a Windows 10 desktop computer that I’ve been working on for years, and I got a new BBB in January and flashed it with the latest image and it’s been working fine on there, no drivers needed as far as I remember. Been able to ssh in via the USB connection and it seems to work great.
But I just got a new MacBook Air (which came with Big Sur 11.2.1), and I’d like to be able to use it on there. I’ve been trying to install the drivers on the getting started page, but neither works. The serial one (HoRNDIS, which is I think the one I need) keeps telling me it won’t work on this version of my computer. I can’t ssh in to either *6.2 or *7.2 and the Network tab of my system preferences seems to think that the cable is unplugged (it’s not).
I’m hesitant to reflash my BBB as I’ve been doing some solid stuff on there and don’t want to lose it.
What can I do? Am I screwed w/o refreshing my BBB or rolling back my Mac version (not happening)? It won’t be the end of the world if I can’t use it with my Mac, but it’d certainly be nice if I could.
Thanks in advance.

This was fixed shortly after release .. BigSur removed support for
ecm, so we swapped to ncm..

https://github.com/RobertCNelson/boot-scripts/commit/b61125c1485bee929340cacc06c85c6fcfd678bc#diff-37b07cb09a69a3f886bdc703e8d66695b328c840450e055d70c3e0f1af793e8c

Just grab one of the latest testing images.. :wink:

https://rcn-ee.net/rootfs/bb.org/testing/2021-02-22/

Regards,

link Index of /rootfs/bb.org/testing/2022-04-01/buster-iot

I was able to find another link for test images and try another, newer one than the one on the front beagleboard page and that one let me connect without issue.

Hi @RobertCNelson, I am unable to ssh to my pocket beagle over USB at beaglebone.local or 192.168.6.2 – though the volume mounts as an external drive. I too have a newer M1 mac. Your “latest testing images” link is broken. Do you have an updated one? Is there a workaround? I also tried ubuntu via parallels but maybe this still requires something on my mac I don’t have. I also tried three cables but that can’t be the issue I don’t think since the pocket beagle volume mounts.

Hi @Andrew_Blair either of these will work:

https://forum.beagleboard.org/tag/bbbio_debian

Regards,

2 Likes