Can't install my USB Wifi Adapter (MT7601 Chipset)

I have been trying to install my USB Wifi Adapter doing the following tutorial:

https://docs.google.com/document/d/1-CIGQYdk8ZhU3D3UCNn70jc7C9HdXvEZAsiNW71fGIE/edit

but when I do this, It sends me this error message:

root@beaglebone:~# curl -kO https://googledrive.com/host/0B_JlgOR4VNe0Sjg4ei0ySEY4aUE/mt7601.tar.gz

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 294 0 294 0 0 613 0 --:–:-- --:–:-- --:–:-- 803

root@beaglebone:~# tar xzvf mt7601.tar.gz -C /etc/Wireless/RT2870STA/ RT2870STA.dat

gzip: stdin: not in gzip format

tar: Child returned status 1

tar: Error is not recoverable: exiting now

root@beaglebone:~#

If I tar xzvf the file It says that it is not in gzip format, and if I do the file command it says this:

root@beaglebone:~# file mt7601.tar.gz

mt7601.tar.gz: HTML document, ASCII text

So it doesn’t let me to open the file.

Seems curl somehow is not fetching the correct file, and saves something like a "404 error" or whatever as the .tar.gz file.

Perhaps you could download the mt7601.tar.gz with a normal browser and later transfer it to the bone. This file downloaded here nicely, and is a valid gzip.

Jacob, what distribution are you using? If it is anything recent, it most likely already includes support for the wifi module.

Thanks Casey! I’m using the:

I have just installed it yesterday in a SD card. The lsusb command shows me the wifi adapter conected but it doesn’t work. And do you know why I can’t find the connman directory in my bbb?

sudo ifconfig -a

should list a "ra0" device

then: in /etc/networking/interfaces

auto ra0
iface ra0 inet dhcp
    wpa-ssid YOUR-SSID-HERE
    wpa-psk YOUR-PASSWORD-HERE

Connman is not installed by default in debian.

Regards,

Jacob

The Debian image does not have Connman. Instead, I believe it includes the Wicd network manager. I would suggest trying the wicd-curses utility to configure your access point.
To make sure the wireless interface is actually up, type
ifconfig -a
and make sure the ‘ra0’ interface shows up

There is no interfaces directory, I don’t know why

It shows up in ra0:

eth0 Link encap:Ethernet HWaddr 7c:66:9d:5a:56:57

BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Interrupt:40

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:36 errors:0 dropped:0 overruns:0 frame:0

TX packets:36 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:2928 (2.8 KiB) TX bytes:2928 (2.8 KiB)

ra0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb0 Link encap:Ethernet HWaddr 9e:b5:5e:e7:41:8d

inet addr:192.168.7.2 Bcast:192.168.7.3 Mask:255.255.255.252

inet6 addr: fe80::9cb5:5eff:fee7:418d/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:179 errors:0 dropped:0 overruns:0 frame:0

TX packets:88 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:17901 (17.4 KiB) TX bytes:20066 (19.5 KiB)

I am going to try with the wicd-curses, thank you!

"/etc/network/interfaces"

Finger slip in my previous email.

Regards,

Thank you Robert!!

Casey, can you help me with the wicd-curses, I found this:

http://www.raspyfi.com/wi-fi-on-raspberry-pi-a-simple-guide/

But it is not for making my access point :S

One of the problems with "wicd-curses" and why i wish i didn't enable
it*. It can only handle one interface, so it's setting up eth0. So
you'll have to move that to /etc/network/interfaces first.

* It does boot faster, with how i set it up by default.

Regards,

Thank you again Robert,
So can you help me with that?
What do I have to move to /etc/network/interfaces ??
How do I give a wifi IP adress to my bbb?

Look, the adapter is working now but I can’t make it ping google

Looks like it’s only taking an IPv6 address. You should really learn how to setup networking on Debian.

google → howto Debian networking → https://wiki.debian.org/NetworkConfiguration

do the same for wicd-curses, or whatever package that was you mentioned earlier.

Then use variations on the keywords like wifi, or wireless configuration and put it all together. That is the only way you’re going to learn :slight_smile:

It’s not that I dont want to help, but you’re asking very basic questions that you can very easily be solved via a good google session.

Thank you William!
I’m so agree with you, I really like to learn but needed some orientation. Let me try your tips.