Can't load my BeagleBone Black anymore...

So, I just got a BB Black. I started it up, hooked to my mac. It didn’t present the USB drive the first time, but after random thoughts and eventually re-plugging the USB, it did so. I then was able to load all of the drivers, and ssh to it.

Then, I tried to load something onto a micro SD card I’d inserted after boot for a friend. (a raspberry Pi image, but) dd to the device via ssh, and eventually it ended, and I think the BB Black went crazy. At least my ssh connection died, and I was unable to ping it from my mac. So, I rebooted it.

Now, I can’t talk to it at all. It presents no USB disk devices, and doesn’t seem to be presenting any network or serial connections. I don’t have a micro-HDMI available, but is that my only option at this point?


  • Chris

Go to the support Wiki listed on the white card that came in the box.

Look under menu item 10 for Angstrom.


Thank you for the pointer to the wiki, however that area of that page only talks about where to obtain software. My problem is that I’m unable to succesfully communicate with the BeagleBone Black, so I wouldn’t be able to load software anyway.

Unless you were suggesting that local drivers found at might be newer and better than the ones I originally installed from the BeagleBone Black, I’m not sure anything on that wiki addresses my problem. I will continue to look at the links however.

  • Chris

All you need the PC for is to make the SD card. No communication between the PC and the card required for updating the Software. Take a look at the instructions part of that page.

I also suggest changing out the USB cable.


Thanks. Okay. Of course, I don’t have said micro SD card anymore, since it was something I was attempting for someone else. But, you’re suggesting I [likely] need to load a new image onto it. I can see that as probable as well. Thanks.

I’ll have to get more hardware for this project. Including a micro-HDMI cable, while I’m at it. :slight_smile:

  • Chris

micro hdmi cable,5v power suply 2A, hub with power suply include (dont use the usb hub with out power suply), usb wifi (i use tp-link) is very easy to use with wicd.

after you restore backup from micro sd to you board use gparted to change the size of your micro sd card from 2gb to 8gb (use all space from your card) you must do it in you notebook, cant use gparted in your bbb.

When you micro sd card is 8gb (more than 2gb) dont press boot bottom from you beagle bone when you turn bbb on. just start normal with your card on. Is you press the boot you bbb will not start.

Hi Chris Ross, I hope your problems to connect to bbb are done.
I had same problem, the way i solve it was flashing a fresh image again to eMMC, it sems to me when you turn of the power supply to the BBB without sending a “shutdown” command the BBB does not start the OS correctly.
Sorry for my poor english.
Good look with your projects!!

I wasn’t able to find a 5v power supply, at least not in a store. There were a couple/few options with selectable output voltage, but both of the ones I looked at offered 4.5v and 6v (and others), but not 5v.

If you have a pointer to a good 5v 2a PS, let me know. I’m happy to order one to have, but right now have to suffice with the USB power (powered USB from my display hub).


  • Chris


Okay. Reflashing the eMMC with the 2013.09.04 image/flasher seems to have worked to get it booted. Oddly, the ID.txt on the FAT partition is empty, but the system does boot and display on the HDMI. Actually, looking again, most of the files show up as 0 byte.

What might be wrong? Do I have to do anything to make the files in the FAT partition proper? And, it’s also not showing up to the RNDIS drivers on the network, just as a USB device. I tried reinstalling it (the Mac OS X HoRNDIS package) from the github version that I’d downloaded, and it still doesn’t seem to have brought up the expected network/interface. Is that something unique to the OS that ships with the BBB, and not part of normal function?

Thanks. Let me know any thoughts on the empty files in the FAT partition, and the network connection issue.

  • Chris

Hi, i had similar problems and i uninstall the Horndis then install it again, to uninstall it
hope it helps.

Thanks for the note, but that doesn’t seem to make a difference. And, I still have the issue that the image I loaded onto the BBB eMMC has a FAT partition with many 0-byte files in it, so I think there’s a larger problem.


So I’m not sure what was different the first time I did it, when the IP address was automatically configured on my MAC, but that doesn’t happen now. Using a HDMI and UIO to the BBB, I see it is, and if I attach and manually configure the NDIS interface onto my Mac, giving it the expected address (, everything is back to normal.