Can't ping one of two Beaglebone Black's when running Debian Wheezy

Hi all,

I’m posting here in the hope someone can help me get to the bottom of this networking issue I’m having with one of my BeagleBone Black’s. I have two identical units (Rev A5C) but am having trouble pinging one of them successfully when running Debian Wheezy (debian-wheezy-7.0.0-armhf-3.8.13-bone20.img to be exact).

The Debian installations are booted from two micro SD card’s, which are clones of each other apart from the fact that SD card 1 hands out IP and SD card 2 hands out IP These are both connected to my laptop though an unmanaged switch, and the laptop has a static IP of

If I plug SD card 1 into BBB1 and ping, no problem, I get a response. When pinging with SD card 2 in BBB2 however, no response.

To try to isolate the problem, I left the ethernet setup alone and simply switched the SD cards. The IP’s for each BBB change as expected, but it’s the same one that refuses to respond. As a further test I also switched the network cables going to each BBB, with same result - it’s the same board that doesn’t respond. Finally, I also tried switching over the power adapters used for each board (which are identical, but still) - and still the same board doesn’t respond.

Following this I suspected a hardware fault with the ethernet adapter, but when running the default Angstrom image from eMMC I can ping each board successfully on

Conclusion: it doesn’t seem to be a hardware fault, but it doesn’t quite seem to be a software fault either, but there’s definitely a fault somewhere! Any ideas?


udev . . .

Read the whole section.