Cape issue

Hi, I am currently trying to use the CBB Serial cape ( and can’t get it to work.

Kernel release of my BBB : 3.8.13-bone80

I’m using a USB to RS232 adapter (well recognized on my host computer) with the UART2 RS232 (J1) connector.

Minicom connection (9600bps / 8bits / no parity / 1 stop bit on both ends) is not working

I also tried with the pyserial library, here is my source : :

#!/usr/bin/env python

import serial, time

ser = serial.Serial( port='/dev/ttyUSB0', baudrate=115200, )

while 1:

x = ser.readline(10)

print x time.sleep(1)

`` :

#!/usr/bin/env python

import time, serial

uart2_file = '/dev/ttyO2'
baud = 115200
ser = serial.Serial(uart2_file, baud, rtscts=True)
while True:



Once again, to no avail.

The cape isn’t automatically recognized by the beagle so I have to manually load the overlay (here is the one I use :, I also tried the one given in the manual)

Output of cat $SLOTS :

root@beaglebone:~# cat $SLOTS
0: 54:PF---
1: 55:PF---
2: 56:PF---
3: 57:PF---
4: ff:P-O-L Bone-LT-eMMC-2G,00A0,Texas Instrument,BB-BONE-EMMC-2G
5: ff:P-O-- Bone-Black-HDMI,00A0,Texas Instrument,BB-BONELT-HDMI
6: ff:P-O-- Bone-Black-HDMIN,00A0,Texas Instrument,BB-BONELT-HDMIN
7: ff:P-O-L Override Board Name,r01,Override Manuf,cape-CBB-Serial
8: ff:P-O-L Override Board Name,00A0,Override Manuf,BB-UART2-RTSCTS

Pins are set according to the user guide (all jumpers on J5 and HDMI disabled for flowcontrol).

Any idea on what might cause the issue ?

First thing I would do is loop back tests on both ends so I know for certain what is working and what is not.