cloud9-image fails: libacl not found

I’m new to bitbake, trying to build the cloud9-image for Beaglebone. On my build computer I’m running Ubuntu 11.10 (32 bit). Ubuntu is running under Parallels with about 1.5G RAM.

After downloading the setup-scripts, setting up my configuration for the Beaglebone, and making sure I have what I need in apt-get, I run bitbake cloud9-image. It chugs along for a while and then hits an error:

checking acl/libacl.h presence… yes
checking for acl/libacl.h… yes
checking for acl_get_file in -lacl… no
configure: error: *** libacl not found.
ERROR: oe_runconf failed
NOTE: package systemd-git-r23: task do_configure: Failed
ERROR: Task 191 (/home/zippy2/src/beaglebone/setup-scripts/sources/meta-openembedded/meta-oe/recipes-core/systemd/, do_configure) failed with exit code ‘1’
NOTE: Tasks Summary: Attempted 2028 tasks of which 2027 didn’t need to be rerun and 1 failed.

Summary: 1 task failed:
/home/zippy2/src/beaglebone/setup-scripts/sources/meta-openembedded/meta-oe/recipes-core/systemd/, do_configure
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

I’m not sure what to do about the libacl error. Any suggestions?

I’ve attached the that the error references (5.42 KB)

And here’s the openembedded configuration file from ~/.oe/environment-oecore

I added .txt to the filename so the attachment would work.

environment-oecore.txt (1.04 KB)


I’m trying the same thing but with a different error:

NOTE: package debianutils-2.30-r0: task do_unpack: Failed
ERROR: Task 2555 (/home/jerrill/projects/angstrom/setup-scripts/sources/meta-openembedded/meta-oe/recipes-support/debianutils/, do_unpack) failed with exit code ‘1’

Any ideas about this one?


Ack, I posted a reply but I think my browser ate it.

Yes, I now hit the same error as you. The build is requesting an old version of debianutils, and the error is that the tar.gz file it wants is not on the server it’s requesting it from (debianutils_2.30.tar.gz, where the oldest version on the server is debianutils 3.4)

The url it’s trying to fetch is:

This is set in …/setup-scripts/sources/meta-openembedded/meta-oe/recipes-support/debianutils/

I assume the fix is either: 1) find a server that has this old version and update the url, or 2) tell the build to pull a newer version of debianutils from

I created a bitbake configuration file to work around this problem. See attached. Drop this in the same directory as the broken script:


with filename

Note: this hasn’t been tested aside from getting past the above-mentioned build error,

Also, later in the build I hit another issue where breaks (1.73 KB)

Looking into the mime-support error, it’s for the same reason - an older version no longer on the debian server.

I’ve attached an updated bitbake file for mime-support. Put this file in:

/setup-scripts/sources/meta-openembedded/meta-oe/recipes-support/mime-support (2.26 KB)

After the previous build point worked, I hit another broken bitbake script for screen.

I posted my fix - a modified .bb for screen - in this thread:

Hi Pat,

my build went into the same error and says that libacl is missing.
Did you fix the problem already?
My workarround for the missing libraries is to search them on the web
and save them in the angstroms download folder.
Since doing so, the build continous (debian_utils, mime, a.s.o)

The beaglebone build seems to be broken so far 3 libraries seem to be missing.

Kind regards,


Gerrit, I deleted my build directory and then rebuilt, and the libacl problem went away.

The libacl error may have been from my laptop shutting down during the build process and leaving things in an indeterminate state.