Compilation fails with dtsi file not found.

Hi

I am trying to compile the 4.1 kernel as per this eewiki link. I started on a fresh The kernel compiles but the compilation script bombs when it gets to the dtbs stuff because it can’t find a file. Help appreciated.

Thanks, now fixed in git..

Regards,

Thanks for looking at this so quickly. Unfortunately I’ve been away and am only getting back to this now.

I seem to have the same problem. This is on a BBB for which I am trying to compile a 4.1 kernel via “git checkout origin/am33x-v4.1 -b tmp”. I kicked things off with a ./build_kernel.sh expecting that that would have pulled in your fix. The file “am335x-boneblack-1ghz.dtsi” itself appears to be missing still. Is there anything else I need to do to get this file pulled in?

[dk@laptop bb-kernel]$ find . -name am335x-boneblack-1ghz.dtsi
[dk@laptop bb-kernel]$

By the way, I did notice the warning below early on (see bold text). Perhaps related?

Resolve operation not in progress, we are not resuming.
git tree is clean…
[v4.1.3-bone14.1 1afaa31] empty cleanup commit
1 file changed, 2808 insertions(+)
create mode 100644 arch/arm/crypto/sha256-core.S
HEAD is now at 1afaa31 empty cleanup commit
Checking out files: 100% (10724/10724), done.
Switched to branch ‘master’
Your branch is ahead of ‘origin/master’ by 1 commit.
(use “git push” to publish your local commits)
Already up-to-date.
:366: warning [p 5, 4.7i]: can’t break line
Deleted branch v4.1.3-bone14.1 (was 1afaa31).
Checking out files: 100% (10650/10650), done.
Switched to a new branch ‘v4.1.3-bone14.1’

Once again, the error is below. Help appreciated!

arch/arm/boot/dts/am335x-bonegreen.dts:19:38: fatal error: am335x-boneblack-1ghz.dtsi: No such file or directory
#include “am335x-boneblack-1ghz.dtsi”
^
compilation terminated.
scripts/Makefile.lib:293: recipe for target ‘arch/arm/boot/dts/am335x-bonegreen.dtb’ failed
make[1]: *** [arch/arm/boot/dts/am335x-bonegreen.dtb] Error 1
make[1]: *** Waiting for unfinished jobs…
DTC arch/arm/boot/dts/am335x-evm.dtb
arch/arm/Makefile:319: recipe for target ‘dtbs’ failed
make: *** [dtbs] Error 2

You need to update the repo...

git checkout master -f
git branch -D tmp
git pull
git checkout origin/am33x-v4.1 b tmp
./build_kernel.sh

Regards,

I needed to, indeed! Everything seems to have compiled this time around. Thank you very much.

Hi Guys,

unfortunately i am also not able to find this file am335x-boneblack-1ghz.dtsi

could you provide me with the exact location.

Thank you
Attila

If you need that file to override your clock frequency, then your git
checkout is too old..

as it's now taken care of by the driver...

Regards,

Hi Robert,

thank you for your prompt reply.
I am in your dtb-rebuilder repo and trying to use the 1wire driver since monday unsuccessfully.
I am so disappointed now since with arduino it succed in an hour…

Thx
Attila

I am so disappointed now since with arduino it succed in an hour…

So use your Arduino . . . unless you have something actually constructive to say.

I asked a question and pointed my frustration wit linux! You are the one not constructive!!
But do not worry man! I went to the previous debian image and made it in half an hour.
Thank you for your nothing.

Wah ?

I asked a question and pointed my frustration wit linux! You are the one not constructive!!
But do not worry man! I went to the previous debian image and made it in half an hour.
Thank you for your nothing.

So, you asked a question, you got an answer, after which you felt compelled to compare a very capable embedded linux system, with a bare metal embedded system for 5 year olds. Did you expect a pat on the back ?

You’re right. What I said was not constructive. I return comments in kind. Maybe next time you’ll actually come back with “Thank you Robert !” Instead of being a jerk.

Me ? I don’t have to worry about being a Jerk, I can actually figure things out on my own - Given enough time.

You frustrated faggot!

This was my first sentence in my answer:

“Hi Robert,
thank you for your prompt reply.”

You are the one that makes BBB community worst! It is no wonder that this platform is so weak…

I do not think it is a good promotion to BBB. I will swithch to other plattform asap. And i will not recommentd

this community to nobody!

You frustrated faggot!

This was my first sentence in my answer:

“Hi Robert,
thank you for your prompt reply.”

You are the one that makes BBB community worst! It is no wonder that this platform is so weak…

I do not think it is a good promotion to BBB. I will swithch to other plattform asap. And i will not recommentd
this to nobody

2015-12-10 22:59 GMT+01:00 William Hermans <yyrkoon@gmail.com>:

Hello Nelson,

I am currently trying to get the one wire working with a beaglebone. I have done various paths but can’t seem to get any to work. Would you be able to direct me to a webpage that works for the beaglebone using the lastest kernel and a ds18B20?

Thanks,

Cory

Download the latest iot image:

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#Jessie_Snapshot_iot

disable cape_unversal=enable (open /boot/uEnv.txt)

reboot

then follow:

https://github.com/beagleboard/bb.org-overlays/blob/master/examples/BB-W1-P9.12/example.sh

(hint, p9.12 is the gpio used in that example)

Regards,

just got the newest version now I’m looking to do your next step. I don’t follow your disable cape_unversal=enable (open /boot/uEnv.txt) Are you asking me to remove the # from this? I also don’t have disable cape_unversal=enable

tHanks,

Cory

cmdline=coherent_pool=1M quiet cape_universal=enable

Remove, the bolded text. Or better yet, copy that line. Remove that text, then comment out the original line.

One more thing. make sure all other cmdline= lines are also commented out. As the last line will likely override previous lines.

thanks found it onto the next step