config-pin does not work for all pins on BBBW

On BBBW, when I do ‘config-pin -q P9.28’, I get the following error: “Cannot read pinmux file: /sys/devices/platform/ocp/ocp*P9_28_pinmux/state”.
When I do ‘config-pin -q P9.22’, it works fine. I have loaded cape-universala previously with the following command “config-pin overlay cape-universala” so config-pin should work for all the pins. How do I fix this problem. I’m trying to get spidev1 to work on BBBW. Thanks.

I am having the same problem with P9_31.

I think it is because you need to disable the audio but I can not figure out how to do that.

Disable the HDMI virtual cape in your uEnv.txt file. This leaves the
HDMIn (HDMI with no audio) enabled, so you will still have a display.

In uEnv.txt:

This solved my problem

This solved my problem