Connecting to Windows shares from BPlay xfce file manager

Is installing sudo gvfs-backends gvfs-bin a prefered method to get the gui file manager to connect to Windows shares? On one sd install I did this and it worked OK except it did not resolve hostnames unless I did a full name to router like

I am not clear on what you are doing, however. On your big box.

$ su -
#echo " target_name target_name.localhost" >>/etc/hosts 

Now you can

$ssh target_name

When you have issues and cannot resolve by hostname, it can be your network/router/who knows. Simplest and most reliable is to append the hosts file.

This problem is only with thunar in the xfce gui. The router works fine with command prompt ssh. samba-client is like thunar in that it needed ip in 192.168.1 , and I don’t think I tried samba-client with th “fqdn”. It’s no big deal for one off install, but a support problem for “it just works”. I’ve never had such a problem with Centos, RedHat, Fedora, Mint, Ubuntu on Gnome desktop. There was a post about supercede and prepend with dhcp config but some said it did not work anymore.

I’ll look at hosts, but everything is varying dhcp addresses, so unless things have improved on the fixed address part, an alias would not work.

Might consider getting a modern router or broadband modem. Seems like your DHCP reservations using MAC is not working.

As far as a thunar specific issue, your guess is as good as mine. Since you are able to use that config with others it might very well be an issue that is tied to thunar.

Also, might help to light up wireshark and see what is going on.