Connman and WiFi setup

I am new to connman, so this might be a basic question. I am trying to setup the WL8 WiFi cape with a BBB. I am using recent console image and kernel:

hk@wbct1:~$ uname -a
Linux wbct1 4.1.12-ti-r29 #1 SMP PREEMPT Mon Nov 9 22:46:19 UTC 2015 armv7l GNU/Linux
hk@wbct1:~$ cat /etc/dogtag console Debian Image 2015-11-13

With the right device tree loaded, the cape works after configuring connman. The problem is that WiFi does not connect after a reboot. I have to manually run “connmanctl connect wifi_blah”. After that, things work normally. I can use ifconfig up/down to change state without using connmanctl. It’s only after a (re)boot that it does not autoconnect. I have autoconnect turned on for the AP I am using the settings file contents below:


Ethernet is attached and it does connect on (re)boot.

Mark, did you ever solve this? If so, how? I’m having the same problem but with a USB WiFi dongle. It worked fine with the old method of editing /etc/network/interfaces and installing the wifi-reset service. But I’ve upgraded to Debian 8.6 for the beaglebone and the old method doesn’t work any more. As you say it connects just fine with connmanctl, but doesn’t reconnect after a reboot, even with “config wifi__ autoconnect on”. Nor does the old wifi-reset service solve the problem.

This post I wrote in June needs to be refreshed, but the wifi part I believe is still correct:

See if this helps you get up and running correctly.


Thanks Stéphane. I believe what you have is equivalent to the instructions that appear as comments in the /etc/network/interfaces file that ships with Debian 8.6. They connect OK, but the connection is not re-established after a reboot, despite adding the command “config wifi_ autoconnect on”. The full set of commands I used was:

#connmanctl> tether wifi disable
#connmanctl> enable wifi
#connmanctl> scan wifi
#connmanctl> services
#connmanctl> config wifi_managed_psk autoconnect on
#connmanctl> agent on
#connmanctl> connect wifi
#connmanctl> quit

The * above corresponds to two great long strings of hex digits separated by an underscore, which you obtain by looking at the output of the “services” command, to the right of the SSID you want. Fortunately tab-completion works for those.

But after a reboot the WiFi service does not come up. I read a theory that this is because the connman service runs too early, e.g. before the USB hardware is initialised.

My friend Mike Van Emmerik came up with a way to make it work. We installed the WiFi Reset Sevice as described here:
but before running we edited so it only does:

sleep 30
connmanctl connect wifi_*_managed_psk

where * is the same string of hex-digits and underscore as above.

This made the WiFi connection re-establish after a reboot, but only if we unlpugged our wired ethernet connection! I would love a solution to this last remaining problem.