connman issues on latest Debian 8.4 release?

Accidentally posted this on the beaglebone google group… annoying.

connman works just fine for my three different RTL81xx based USB WIFI adapters on the Debian Jessie 8.3 release, but wifi seems dead on the Debian Jessie 8.4 release (wifi scan either hangs, or does not find anything). Same behavior on BeagleBone Black and Green, powered with external bricks.

I run on both 8.3 and 8.4:

$ sudo su


enable wifi
scan wifi

At this point, I either see my AP (Jessie 8.3), or nothing (Jessie 8.4)

Checking ‘technologies’ on both releases does show WiFi is present, and powered.

Is there any config magic required before using connman with Debian 8.4 release? Unfortunately I overwrote my SD card before capturing the kernel log, but it seemed like the rtl firmware was loading fine, with no errors being reported.



Hi Mike

Hi Robert,

Thanks a bunch!

I appreciate your quick response- sorry if this was posted somewhere already. I did not know tethering would cause this, and probably never would have tried disabling it :slight_smile:


Hi Robert,

I would think that the need for tethering would be the exception so I’m not sure why you would set this on by default.