CPU frequency problem on BB-xM Rev. C with Nitty 11.04 demo image

Thanks Robert, I had the Ubuntu demo image of Nitty 11.04 running on
my BB-xM Rev. C. Everything looks fine, except the cpu frequency:

ubuntu@omap:~$ sudo cat /proc/cpuinfo
Processor : ARMv7 Processor rev 2 (v7l)
processor : 0
BogoMIPS : 503.12

Features : swp half thumb fastmult vfp edsp thumbee neon vfpv3
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x3
CPU part : 0xc08
CPU revision : 2

Hardware : OMAP3 Beagle Board
Revision : 0020
Serial : 0000000000000000

ubuntu@omap:~$ sudo cat /sys/devices/system/cpu/cpu0/cpufreq/
ubuntu@omap:~$ sudo cat /sys/devices/system/cpu/cpu0/cpufreq/
ubuntu@omap:~$ sudo cat /sys/devices/system/cpu/cpu0/cpufreq/

Well, the omap3 is only running at 300MHz ?

So, I changed the mpurate to 1000 in the boot.cmd and updated the
booting parameters with ´. /boot/uboot/tools/update_boot_files.sh´ .

What I got from the bootlog:
[ 0.000000] Kernel command line: console=ttyO2,115200n8
console=tty0 root=/dev/mmcblk0p2 rootwait ro vram=12MB omapfb.mode=dvi:
1280x720MR-16@60 fixrtc buddy=none mpurate=1000
[ 0.125000] Switched to new clocking rate (Crystal/Core/MPU):
26.0/332/1000 MHz

But nothing really changed with the CUP frequency :frowning:

Does anyone has an idea how I could change the CPU frequency? Thanks
for the hints in advance!

Best regards,

Hi Hans,

In it's current form it's actually switching between 300/500/800 Mhz
based on demand.. For some reason the BOGOmips never get updated after
it's initial bootup setting of 500Mhz.

The 1Ghz setting is actually ignored since the OPP point for it isn't
currently enabled..


Hi Robert,

thank you for the hints, as well for your excellent efforts! :slight_smile:

Now, I can understand the the 300MHz shown in /sys/devices/system/cpu/

Still looking forward to any update regarding the full support of 1GHz
with ubuntu on BB-xM...

Best regards,