Alright so I’ve been going in circles with this for hours,
I’m using debian sid and I’m trying to compile a kernel for my BBB and I keep stumbling over this error:
sudo apt-get install gcc-4.4-arm-linux-gnueabi
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
gcc-4.4-arm-linux-gnueabi : Depends: libgomp1-armel-cross (>= 4.4.6-15) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Why is it not going to be installed? Because it depends on gcc-4.8-base-armel-cross which has no installation candidate. People have fixed this in the past by using the unstable emdebian repo but that doesn’t work. It doesn’t exist in the unstable repo. I’ve also read to only use stable and that has even more dependency errors.
What’s the fix here?
deb http://www.emdebian.org/debian/ unstable main