Debian 8.6 QTerminal has garbage characters with VNC

Installed bone-debian-8.6-lxqt-4gb-armhf-2016-11-06-4gb.img on a clean 16GB MicroSD card and installed into a brand new Rev C Beagle from Adafruit.

Also connected was the Adafruit 7" HDMI with Touch Screen display, a USB hub along with mouse, and keyboard and FTDI USB 3.3V Serial Cable connected to Beagle TTY0.

System boots within about 20 seconds watched with puTTY on WIN-7 system COM10:. LCD Display takes a bit longer but eventually shows up and is correctly sized for the 800x480 screen and it correctly requested touch screen calibration.

run vncserver, select passwords and then run tightvnc on the WIN-7 desktop.

Run QTerminal and type “the quick brown fox jumped over the lazy dogs” and see garbage.
Run LxTerminal and type the same thing and the characters are not garbled.

Select Preferences LXQT Settings Keyboard and mouse and type into the text field and it’s garbled.

This also happens if Windows Remote Desktop is used for both Qt programs.

It happens on a WIN-7 laptop and it happens on a WIN-7 Workstation. The VNC software is the latest available.

This does not happen if the usb keyboard and mouse are used with the LCD display. This problem was also on an earlier version of 8.6 which is where the screen captures were done.

It does not happen with Idle, Idle3. And since Rev 7.8 wasn’t running Qt the problem doesn’t exist on that system nor the Angstrom release.

After an extensive web search using various key words I can find nothing related to VNC or Qt with this sort of issue.

Any suggestions on how to even start debugging this problem?



One more screen capture that shows a small app developed on and run headless using WIN-7 and VNCserver. No text problems.


Almost a month later. Anyone tried this and duplicated the results?

I’ve run VNC without issues. Haven’t tried your specifics. Next shot I get I’ll load up QTerminal.

Have you tried reporting the issue to QTerminal developers? I’ve seen some other garbled text issues reported in their tracker. Have you confirmed the issue doesn’t occur with a local keyboard?


Kinda late, but I tried what you said and had the same results.
Removing & re-installing qterminal no help.

So I did an sudo apt install lxterminal
sudo apt remove qterminal
sudo apt autoremove

So I simply us lxterminal as I do on other machines. Sorry I can’t
be of more help. BBB is running Debian 9 (stretch). Oh, I’m
running Windows 10 1909 using TightVNC.

I have what appears to be a work around for the problem. BBB vnc garbage.

sudo apt remove qterminal
sudo apt autoremove
sudo apt install lxterminal
sudo apt clean

cd /usr/bin
sudo ln lxterminal qterminal

Now in VNC things work better like VIM