Debian Bullseye IoT Image - WiFi hotspot configuration

Hello,

I am using Debian Bullseye IoT Image 2023-08-05. Kernel version: 5.10.168-ti-r68

I wish to set up wifi hotspot with new SSID and credentials. By default it is coming with " BeagleBone-FBBF".

Not sure which service or config file is managing this. Checked “systemctl status hostapd” and it shows inactive. We have this file “bb-wl18xx-fw” in “/etc/default” but not this file: “bb-wl18xx”

bb-wl18xx-wlan0.service is not available.

Can you please help me in this regard?

Thanks,
Raajeshwar Elangovan

I don’t have a bbb in front of me at the moment so I cannot look things up.

$ systemctl list-unit-files --type service | grep -i "@"

and then

$pstree

So we can see what is installed.

I see these services in list:

systemctl list-unit-files --type service | grep -i "@"
autovt@.service                            alias           -
container-getty@.service                   static          -
e2scrub@.service                           static          -
e2scrub_fail@.service                      static          -
getty@.service                             enabled         enabled
hostapd@.service                           disabled        enabled
ifup@.service                              static          -
modprobe@.service                          static          -
serial-getty@.service                      indirect        enabled
ssh@.service                               static          -
systemd-backlight@.service                 static          -
systemd-fsck@.service                      static          -
systemd-hibernate-resume@.service          static          -
systemd-journald@.service                  static          -
usb_modeswitch@.service                    static          -
user-runtime-dir@.service                  static          -
user@.service                              static          -
wg-quick@.service                          disabled        enabled
wpa_supplicant-nl80211@.service            disabled        enabled
wpa_supplicant-wired@.service              disabled        enabled
wpa_supplicant@.service                    indirect        enabled

This command is returning empty:

$pstree

Meanwhile I tried to edit /etc/hostapd/hostapd.conf file and see what is happening. After rebooting, I am not seeing the AP coming up.

It’s loading /etc/hostapd/SoftAp0.conf

There should be an original template here: /etc/bbb.io/templates/bb-hostapd.conf this get’s copied to /etc/hostapd/SoftAp0.conf

It’s kicked off via:

which got pre-configure via:

Regards,

I tried to start hotspot by using hosapd.

I am getting this error:

Jun 28 14:23:11 BeagleBone hostapd[20422]: nl80211: Driver does not support authentication/association or connect commands
Jun 28 14:23:11 BeagleBone hostapd[20422]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Jun 28 14:23:11 BeagleBone hostapd[20422]: nl80211 driver initialization failed.

When I had interface as SoftAp0, I was getting this:

Jun 28 14:25:36 BeagleBone hostapd[20699]: Could not read interface SoftAp0 flags: No such device
Jun 28 14:25:36 BeagleBone hostapd[20699]: nl80211: Driver does not support authentication/association or connect commands
Jun 28 14:25:36 BeagleBone hostapd[20699]: nl80211: deinit ifname=SoftAp0 disabled_11b_rates=0
Jun 28 14:25:36 BeagleBone hostapd[20699]: Could not read interface SoftAp0 flags: No such device
Jun 28 14:25:36 BeagleBone hostapd[20699]: nl80211 driver initialization failed.

Looks like I am missing some network settings. I will flash a fresh Debian Bullseye IoT Image and see how it is working.