debian jessie: nodejs users (v4.2.3 now available)

Some of you may know, we have a secondary repo for nodejs who’d like to move off of 0.10.38:

WARNING, bonescript and a few other default nodejs libraries haven’t been ported to 4.2.x

sudo nano /etc/apt/sources.list (add:)

deb [arch=armhf] jessie main

Then run:

sudo apt-get update ; sudo apt-get upgrade

Current workarounds:

cloud9ide, make sure you run:

sudo apt-get install c9-core-installer --reinstall ; sudo reboot

Wheezy users, sorry gcc is just too old, you’ll be stuck on 0.10.38 (i’m trying to atleast give you: 0.10.41)


Wheezy users, sorry gcc is just too old, you’ll be stuck on 0.10.38 (i’m trying to atleast give you: 0.10.41)

Does 0.10.41 really offer that much in the way of improvements ? Also, why is gcc too old ? Something that is potentially portable, or not ?

Just a few cve fixes... but against it's built-in openssl, which got
ripped out by debian anyways.. still shifting thru the diff..

gcc-4.8 is needed for > 0.10.x (not sure about 0.12.x, but defintelly 4.2.x)


hmmm . . .


I’m considering setting this up and testing. Currently working on an x86-64 Nodejs server, when I ran into that. Taking notes for setup so should be pretty much a copy paste experience for the BBB.

Scratch that. This version does not seem to work well with the packages I intend on using.

4.x is the new LTS version whilst 5.x is “stable”. I would stick with 4.x and it is a HUGE improvement over the older versions as they have now merged with iojs which kept up to date with V8 improvements.


I’m probably going to stick with 0.10.41

No luck with 4.2.x?


Can’t install 4.2 on an x86 / x86-64 system through APT. It pulls in 5.2.x, as does the crappy Nodejs wiki script.

This takes me back to the 90’s again, when many things( Linux ) failed on installation, and it’s really starting to aggravate me.

The packages I’m having issues with is phantom.js, which is required for Markdown-PDF. I’ve read that apt-get install nodejs-legacy may fix the problem, so I’ll give that a go before I call no joy. But it’s a real pain in the ass, that one has to hunt all over the web for potential fixes to these issues, and then there is no guarantee it’ll work . . . this should “just work”.

Another issue I was having was with node pathing issues. Also, the Jessie package was not installing correctly, e.g. the deb purported to install, but there were no binaries anywhere that I could find. Total amateurish 90’s package maintainer BS . . .

Actually, APT attempts to pull in 0.10.33 I think the install output was saying. Either way, it was not working correctly.

Giving this a shot. Sure beats having to find a good method for building manually. Seems to be working great so far for v4.2.3

Well, phantom.js installed fine with node v4.2.3. That build script is awesome, reminds me of your scripts Robert :wink: Only 57 lines of code too . . .