Dependencies and installing issues while installing a new package


I am a newbie in using beaglebone black and as well as using linux. I want to install OpenGL to do some Graphics programming on the board. So i searched and found that FreeGlut is a nice option. I downloaded all the required files and packages using apt-get command. I tried to install it but there were errors while installing and package was not installed. there were plenty errors (I have also uploaded the detailed error file) but this is the summary dpkg gave me.This happens whenever i download any package and try to install it. I have upgraded and updated every packages. With the help of Aptitude i found that this packages(shown in image) have partial download and installation. I tried to complete it but nothing happened. I tried couple of hacks from the internet but nothing worked. how do i solve this ?

errors.log (84 KB)

apt-get upgrade first ?

I have applied apt-upgrade and apt-update command before installing. I even used “aptitude” to download and update packages but nothing has happened.
(I forgot to mention that debian version is 7 and beaglebone black rev C id it comes in any use.)