Desperate: BBB not booting itself, cannot be flash, cannot boot from SD card

My dear BBB friends,

I am so desperate that my BBB seems lifeless:

  1. If plug in power (either USB or 5V), the power led will be lit but nothing else will happen. Cannot even connect it through USB.

  2. If flash the eMMC, as I have tried many times, 4 user LEDs will be on but not flashing, which indicates no reaction. It change nothing even if I wait for an entire day.

  3. If boot from the SD card, I can see the login screen pops up asking for username, if I enter “root”, it will just flash and then a new identical command asking for username pops up again. If I put something else, it will just reply “login incorrect”.

I am desperate… I think I have basically done all the steps in the wiki or the official website.

What can I do now? My BBB is basically not doing anything now.

Any comments will be appreciated and thanks in advanced.


So, are you using the instructions on the support Wiki?


Yes, basically every single step.

I also formatted the SD card.

Does not work well…

Are you using USB power?


I tried both USB and 5V independent power supply.

The instructions say not to use USB. What about Ethernet? Is it plugged in?


No Ethernet.

If you follow the instructions exactly, they work. We have done this 82,000 times so far. We use the same process for every board we ship.

If you are sure you have done everything exactly as it says, and it does not work, then request an RMA and we will look at it for you.


Okay cheers, I am doing that now. And I am wondering how can I identify the serial number?

It is the big white label on the expansion header. Just like the Wiki and SRM says. The SRM actually has pictures.


Much much obliged!!