Did I kill my BBB?

I have been trying to configure LinuxCNC on my BBB for some time. Everything was almost working, but when I tried to turn on the BeagleBone today, it wouldn’t start. No power led, nothing. I was using the AC/DC converter I got from Adafruit, so it’s not low quality (I assume). I also tried plugging it in via usb, same result. Any ideas?

Since you’re booting from SD card is the card Fully seated? Just checking, as it’s in a spot easily bumped and I’ve knocked it out a couple times without realizing it then thought “oh, what happened, it’s dead!”. Also to boot from SD you need to depress the boot switch. really though to do much debugging on the black you need a serial console cable. you can also check which of the power rails are up. do you have 3v3 on the headers? What do the 4 lights show? Also what voltage are you showing on the power adapter under load and across both vcc_5v and sys_5v. If you have any capes stacked / plugged in unplug them and test the black alone. Remember to simplify. no matter what, all the best in getting things going as I too have done stupid things that set me back a week or more. the good news is that you will get past it and get things working.


Contact cicuitco, and ask for an RMA.

No power LED from either barrel jack or USB port is not a good sign.



I’ve been trying the BBB alone :frowning: that was my first step. I have no lights what-so-ever. Still have 5.15v at the plug. I have power at the 5v rail, (i assume it’s powered from the plug) but not from the 3.3v rail.

Then your board is dead. You killed it.