Did I kill my BBB?

I have been trying to get my BBB to work with LinuxCNC. Everything was working fine until I tried to power it up today. After I plugged it in, the power light didn’t come on, or any other lights. Was using an AC/DC converter from Adafruit, also tried usb, no luck. Is it dead?

Did you check to see if the barrel plug had correct polarities ?

Ya, it was powering the board fine for the past 6 months. I checked the voltage, 5.14v

Try hitting the reset and power buttons? http://elinux.org/images/7/76/CONN_REVA5A.jpg

Ya, no change

Ok, so could be that the OS image some how became corrupt. Is this on uSD, or eMMC ? And do you issue shutdown now -h, before pulling the power ?

Technicaly this would be a u-boot issue in the case of becoming corrupt, since the led status doesn’t change.

I was booting from uSD. I tried to download a new image but still no change.

OK so next step is to get a serial debug interface working. Which means you may need to purchase a 3v3 compatible FTDI serial <-> usb adapter. Known working models listed on circuitco’s pages I believe.