Directly writing to the eMMC through the expansion header?

tl;dr After trying to get my BBB to update or boot from the microSD card, I mistakenly attempted to remove the MLO file from the eMMC partition, thusly bricking my device. I want to attempt to use the exposed eMMC pins in the header to directly write to it and reimage the flash. Possible?

I have been trying for the past couple weeks to get my BBB to boot from the uSD slot, doing a variety of button holds (boot, reset+boot, etc), using a variety of power supplies (initially tried usb, upgraded to beefy 5V10A), and a variety of images (Angstrom, Ubuntu, Debian, both flasher and boot).

After unsuccessfully getting it to boot into the uSD card, I attempted one forum post which suggested renaming the MLO so that it would force it to use the uSD. Unfortunately, that has not worked, and now I am left with a brick. Debug serial is a dead line, and it will not boot to anything.

Before I give up on it completely, I want to try one more thing: using a second micro, writing a hardware imaging script which will interface to the eMMC directly, reflashing it back to a default state.

My questions are this:

Will this interfere or cause problems with the processor?
Is the eMMC locked by the processor, requiring the use of the password bits to enable write mode?
Before I start down this road, what are the means for booting from the serial or USB connections?


The processor connects to these pins, so that will be an issue.
The eMMC is not locked by the processor.
I would not attempt this as it is likely to damage the processor.

The reflashing process that we have on the support Wiki should reflash it. You need to make sure you follow all the steps exactly.

There is a USB and serial boot mechanism, but currently there are no tools available to support this.