disable edid (hdmi, rgb video output)

Hello all

where can i disable the edid from hdmi?
and where can i setup my own edid on the bbb?

(i have several small TFT's which has no edid-possibility)

@raspberry i can simply change a config.txt file for this.

thanks

I’m pretty sure( as I’ve seen it demonstrated a few times ) that there is a kernel config option to change the video output resolution. So here . . .

$ cat /boot/uEnv.txt |grep cmdline
#cmdline=coherent_pool=1M quiet cape_universal=enable
cmdline=ipv6.disable=1
#cmdline=coherent_pool=1M quiet cape_universal=enable video=HDMI-A-1:1024x768@60e
#cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

I’m afraid I do not know much more than that however.

thanks, unfortunately with this i can only adjust the resolution and frame rate. In contrast with the possibility at raspberrys config.txt is this not really much.

So i think about v-porch, h-porch, de-mode, frequency etc...?
Is there a easy way to config this? Or how can make my own Edid directly on the bbb... (not with eeprom)

thanks, unfortunately with this i can only adjust the resolution and frame rate. In contrast with the possibility at raspberrys > config.txt is this not really much.

No, “60e” I’m 99% sure has to do with refresh rate( frequency ). Frames per second has nothing to do with setting up a monitor . . .

So i think about v-porch, h-porch, de-mode, frequency etc…?
Is there a easy way to config this? Or how can make my own Edid directly on the bbb… (not with eeprom)

You could always download the support files for a known working / well respected LCD screen, and pour over the information . . . Either that or do a google search for “linux how to edid config”

how you mean download? My several TFT's (7", 5" etc.) does not support EDID, so i must configure this directly in the bbb. But i really don't know where and how all this configuration can be done? With google i have found only manuals for the raspberry.
thanks

http://elinux.org/Beagleboard:BeagleBoneBlack_HDMI

A lot of information on that link, maybe something there can help you out.

thanks, and yes i already knew this link.
But there is only explained how to read (for debug) the EDID infos. That is not really usefull. I need more functions as only resolution and refresh rate....

So it seems that with a raspberry i have more adjust functions to set the hdmi output-timings?

The video parameters you can adjust via the video= kernel command line
parameter are discussed in the kernel documentation:

https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/tree/Documentation/fb/modedb.txt?id=v3.8.13

If your LCD is connected via HDMI, that should be enough to get it
working. If you are directly connecting to the LCD via the RGB and
sync signals and you need more exact control over the video timings,
you should not use the HDMI driver. Instead, you'll want to disable
the HDMI driver and use the tilcd driver via a custom device-tree
overlay, like this example for a 7" 1024x600 panel with a resistive
touch-screen:

https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-BONE-LCD7-01-00A1.dts#L230

...there are several other example LCD overlays in the same repository.

thanks, and yes i already knew this link. But there is only
explained how to read (for debug) the EDID infos. That is not
really usefull. I need more functions as only resolution and
refresh rate....

So it seems that with a raspberry i have more adjust functions to
set the hdmi output-timings?

http://elinux.org/Beagleboard:BeagleBoneBlack_HDMI

A lot of information on that link, maybe something there can help
you out.

wrote: how you mean download? My several TFT's (7", 5" etc.) does
not support EDID, so i must configure this directly in the bbb.
But i really don't know where and how all this configuration can
be done? With google i have found only manuals for the
raspberry.

thanks

--

For more options, visit http://beagleboard.org/discuss

---

You received this message because you are subscribed to the
Google Groups "BeagleBoard" group.

To unsubscribe from this group and stop receiving emails from it,
send an email to beagleboard...@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/beagleboard/d637ad92-04c5-4837-9301-9b6b6f8d3334%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Are you connecting thru the hdmi or thru the lcd 16bit/24bit interface?

The hdmi, you are limited to the what the nxp framer chip can handle.

For the lcd interface, you can specfy all those random settings..

https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-BONE-LCD7-01-00A3.dts#L252-L285

Regards,

Ok. thanks for this three links @charles and robert.. i will study this, hope it helps. It seems a little bit more difficult as with raspberry.

i should try both interface, because i have special size Tft with integrated hdmi to her rgb but also Tft's with only rgb interfaces. I also have the possibility to set a hdmi to rgb converter (tfp401a)...

thanks, and yes i already knew this link.
But there is only explained how to read (for debug) the EDID infos. That is not really usefull. I need more functions as only resolution and refresh rate…

So it seems that with a raspberry i have more adjust functions to set the hdmi output-timings?

Why do you think you have to provide this additional information? Let the frame buffer driver compute them. Therefor, as William mentioned, specify the cmdline variable in file /boot/uEnv.txt like

cmdline=coherent_pool=1M quiet video=HDMI-A-1:800x480M@60e cape_universal=disable init=/lib/systemd/systemd

Note the “M” after the resolution here. It requires individual calculation of the timings (in contrast to reading them from a pre-defined table, see framebuffer documentation for details). That way you can skip EDID and specify any resolution in a convenient way. I guess RPi provides a similar feature, and you need not manually handle them using the config.txt file.

BR

I guess RPi provides a similar feature, and you need not manually handle them using the config.txt file.

The rPI BSP is a mess compared to the beaglebone. As far as I can tell there is nothing standard about it. However, it does make some things easier. Just as an example, here is some of the file structure, on my rPI3 Rasbian Jessie.

william@rpi:~$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 931.5G 0 disk
└─sda1 8:1 0 931.5G 0 part
mmcblk0 179:0 0 14.7G 0 disk
├─mmcblk0p1 179:1 0 60M 0 part /boot
└─mmcblk0p2 179:2 0 14.6G 0 part /

william@rpi:~$ ls /boot/
bcm2708-rpi-b.dtb bcm2710-rpi-3-b.dtb COPYING.linux fixup_x.dat LICENCE.broadcom start_db.elf
bcm2708-rpi-b-plus.dtb bootcode.bin fixup_cd.dat issue.txt LICENSE.oracle start.elf
bcm2708-rpi-cm.dtb cmdline.txt fixup.dat kernel7.img overlays start_x.elf
bcm2709-rpi-2-b.dtb config.txt fixup_db.dat kernel.img start_cd.elf

william@rpi:~$ cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

william@rpi:~$ cat /boot/config.txt

For more options and information see

http://www.raspberrypi.org/documentation/configuration/config-txt.md

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

Hello, thanks again.

so today i have try now with a HDMI TFT 1280x800 (EDID compatible) to force the Resolution to 800x480.

For this, i have try to edit the uEnv.txt file:

root@beaglebone:/media/root/rootfs/boot# vi uEnv.txt

then i have edit the cmdline as follow, but unfortunately the resolution does not change after restart, so whats wrong?:

uname_r=3.8.13-bone70
#dtb=
cmdline=coherent_pool=1M quiet video=HDMI-A-1:800x480M@60e cape_universal=disable init=/lib/systemd/systemd

##Example

then i have

After the system boots, verify your kernel command line switches are
actually making it to the kernel by running:

  cat /proc/cmdline

...and look through the output of dmesg for hints as to what might be
going wrong.

so what i receive:

root@beaglebone:/# cat /proc/cmdline

console=tty0 console=ttyO0,115200n8 root=/dev/mmcblk0p1 rootfstype=ext4 rootwait fixrtc coherent_pool=1M quiet cape_universal=enable

BTW, i have read following code on a other side in the internet:

kms_force_mode=video=HDMI-A-1:800x480M@60

But unfortunately for me, it's not clear how to implement this correctly in the cmdline?

thanks

There's an example in /boot/uEnv.txt:

cmdline=coherent_pool=1M quiet video=HDMI-A-1:1024x768@60e

remove the "#" and set the video parameters you need.

Regards,

>remove the “#” and set the video parameters you need.

still not working…

okay, post your full, /boot/uEnv.txt

and what rootfs is this?

cat /etc/dogtag

Regards,

Provide your uEnv.txt, /etc/dogtag, and /proc/cmdline and we might be
able to make a suggestion for what to try next. Otherwise, we're just
guessing.

as requested (it seems that uEnv.txt has different directorys?, anyway I have changed uEnv.txt on the directory /media/root/rootfs/boot):

root@beaglebone:/# cat /etc/dogtag
BeagleBoard.org Debian Image 2016-01-24

root@beaglebone:/# cat /proc/cmdline
console=tty0 console=ttyO0,115200n8 root=/dev/mmcblk0p1 rootfstype=ext4 rootwait fixrtc coherent_pool=1M quiet cape_universal=enable

then the uEnv.txt file:

uname_r=3.8.13-bone70
dtb=
cmdline=coherent_pool=1M quiet video=HDMI-A-1:800x480M@60e cape_universal=disable init=/lib/systemd/systemd

##Example
#cape_disable=capemgr.disable_partno=
#cape_enable=capemgr.enable_partno=

##Disable HDMI/eMMC
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G

##Disable HDMI
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN

##Disable eMMC
#cape_disable=capemgr.disable_partno=BB-BONE-EMMC-2G

##Audio Cape (needs HDMI Audio disabled)
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI
#cape_enable=capemgr.enable_partno=BB-BONE-AUDI-02

##enable BBB: eMMC Flasher:
##make sure, these tools are installed: dosfstools rsync
#cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

uuid=682afa8f-f182-4b65-a144-91e06633914d

thanks