Disable framebuffer console

Hardware: Beaglebone black + embest LCD7
Software: TI rootfs + RCN kernel 3.8.13 with sgx modules and xenomai. Kernel config: http://paste.ubuntu.com/7779382/

I want to disable login prompt and console on LCD display. If I disable “Framebuffer Console support” in kernel config, framebuffer is not working at all. No Tux logo on start, Qt and SGX examples don’t write any errors, but don’t work, even cat /dev/urandom > /dev/fb0 shows nothing.
If I enable framebuffer console, everything works good, but with login prompt on screen and /dev/tty1 device assigned to it.
What is the correct way to disable it?