Disable USB ethernet at boot

We’re tying to set up our BeagleBone Black to connect to our network over its built-in ethernet port. This is working inconsistently. As of now, we can only get to the Beagle command line with UART and it can’t ping our outside network.

Meanwhile, the usb0 and usb1 ethernet interfaces still show up in ifconfig.

We think that these might be interfering with the onboard ethernet. How can we disable the USB ethernet ports during boot?

First make sure the image is using nginx


If so, disable it.

$sudo systemctl disable nginx


What image are you using?
I would suspect your networking gear, the BBB is stable on the ethernet.

Turn it back on

$sudo systemctl enable nginx
$sudo systemctl restart nginx
1 Like