Disabling HDMI kills WiFi

Eventually I want to use PRU and want to disable HDMI to have more inputs available. I setup WiFi and verify it works. In /boot/uEnv.txt, I uncomment

##BeagleBone Black: HDMI (Audio/Video) disabled:


and reboot.

Once back in I try to ping my server and get the response: “connect: Network is unreachable”. Trying to use “sudo connmanctl” gives all sorts of complaints such as ‘Method “Scan” with signature “” on interface “net.connman.technology” doesn’t exist’. Re-commenting the dtb line and rebooting allows WiFi operation again (without even need to go through connmanctl again).

Is there a way to disable the HDMI while retaining WiFi?

Output of uname -a
Linux beaglebone 4.4.54-ti-r93 #1 SMP Fri Mar 17 13:08:22 UTC 2017 armv7l GNU/Linux

This has to be done with u-boot overlays:




Thanks! That worked.