Driver does not work for Netgear AC6210 wifi adapter

I am running Debian 9.3 and want to use the Netgear A6210 wireless adapter. I install the driver from this page Afterwards, nothing shows up. I did use sudo service network-manager restart. Using lsinput does not show the wifi adapter, only the keyboard and mouse. Using lsusb and lshw causes the terminal to hang up. Please help.

"what" happened before you tried that random driver?


Nothing happened. Nothing showed up.

I have tried various ways to no avail. Found this page and follow the guide: I did add the two lines as suggested to /etc/NetworkManager/NetworkManager.conf


However, ‘modprobe mt7662u_sta’ freezes the terminal. I retried again with the Debian 9.3 LXQT image. ‘lsusb’ can now see the Netgear wifi adapter plugged in. ‘nmcli’ seems to see something too, but nothing beyond that. network-manager-genome shows the the wired Ethernet connection as 3 separate connections. Anyways, Can someone point me to the right direction? I have attached the content of dmesg. It can see the Netgear A6210 wifi adapter, but nothing is working for me now.

[ 17.028876] nf_conntrack version 0.5.0 (8192 buckets, 32768 max)
[ 17.033397] usb 1-1.3: new high-speed USB device number 4 using musb-hdrc
[ 17.164751] usb 1-1.3: New USB device found, idVendor=0846, idProduct=9053
[ 17.164759] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 17.164764] usb 1-1.3: Product: A6210
[ 17.164769] usb 1-1.3: Manufacturer: NETGEAR
[ 17.164774] usb 1-1.3: SerialNumber: 100

dmesg.txt (27.7 KB)