DSPLink Make

Can someone please explain the convoluted make system for dsplink?

Basic info : As much as I've tried, I cant get bitbake to work.

I used Linux PSP Kernel from the dvsdk.
I am using the toolchain that I downloaded from narcissus.
I have installed the Code Sourcery toolchain. Had to use one path from

It is pretty messed up :s

Anyhow. Editing here and there. I managed to compile the sample
applications successfully!

But now I want to use fstream to read a file and pass it to the dsp
and perform some math on it using dsplib.

Sample app: Loop.

And I got stuck on the gpp side. (Havent tried dsp yet)

I have the following questions.

I get insane errors :s

expected declaration specifiers before 'template'
expected declaration specifiers before ';' token
declaration for parameter 'xxxx' but no such parameter.


Pretty sure i messed up the includes. But i cant figure out what is
what :s

Base_buildos = ? Kernel source? Or more?
Osinc generic?
Osinc platform?
Osinc target?

Guidance please..

It's really easy if you just follow http://www.angstrom-distribution.org/building-angstrom

I mentioned earlier... "As much as I've tried, I cant get bitbake to
I've tried!

Ok. I found one part of the problem.

Its C!!
Not C++

fstream is C++. I was trying to include it.
Should've realized it sooner :s

This is difficult. Don't think my programming is good enough to make a
C++ wrapper for the convoluted(complicated) dsplink...
I'll use C..

I mentioned earlier... "As much as I've tried, I cant get bitbake to
I've tried!

But I see no postings from you on the angstrom-devel list about any troubles, so to me it looks like you didn't try. What didn't work? Did you actually follow all the steps in http://www.angstrom-distribution.org/building-angstrom ? Most people tend to skip steps which is what trips them up.

I was stuck in a git issue. Not the oebb.sh

Without sudo git didn't have read access to some files/folders.
Fetch_head and some other one.
I tried some searching. Used chmod and chown etc.
Didn't work.

With sudo, bit bake gave an error of don't use bitbake with sudo.
Check some variable.

You aren't right that i didn't try.
I just didn't try hard enough.

Primarily because of another issue though. I have to find a place with
stable internet and electricity for longer durations.
Don't ask how i manage without those two. :slight_smile: