emacs on Ångström - no keys

I installed emacs on my brand new BBB, but although emacs starts up, no key ever makes it to into the program.

The installation was as simple as

  1. log in as root using SSH Secure Shell 3.2.9 (see comments below) to 192.168.1.xxx (via the ethernet cable, address assigned via DHCP)
  2. execute

opkg update
opkg install emacs
3) run emacs by typing

No key is recognized, not M-, not C- , not even just a letter (and worst of all, not C-x C-c, which would cause emacs to exit). Same result occurs if I create a text file test.txt and then execute
emacs test.txt

And just to cut off one possibility: note that I’ve been using SSH Secure Shell with emacs for years, and I tested it just now with another system; it works just fine. Obviously, too, it accesses the BBB, because that’s how I entered the commands that installed and executed emacs. And, of course, I’ve rebooted the BBB several times.

Any thoughts?


P.S. SSH Secure Shell 3.2.9 is a very nice TTY program, which I vastly prefer over PuTTY.
Search for
ssh secure shell 3.2.9 download free
and you’ll find various sources, including universities, that offer the software for free, e.g.William & Mary, Dartmouth, Northwestern, UCLA, etc. In other words, you won’t be downloading some cracked and potentially dangerous piece of software.


Do you use the -X switch when you invoke ssh? I was searching for how to install emacs on beaglebone black and found your note. It worked for me, I use:

ssh -X root@


to attach to my BBB and now that I’ve installed gnuemacs, it works correctly, window pops up and all; no problems with key sequences.

I am ssh’ing over from a Ubuntu distribution.

  • RT

I’m using SSH Secure Shell on a Windows XP machine, not ssh on a Linux box, and there’s no -X option that I’m aware of. As far as I can tell from the man page, whatever it is that the -X option does is automatically provided by the SSH program. Also, I’ve used this software for accessing emacs on many machines for years with no bad experiences that I can recall … until now.

I suspect that there’s some flag or option that has to be adjusted on the BBB side, either for the shell or more likely for emacs, but I have no idea what it might be.

A little more googling and I see that there may be some bug in emacs that causes this. So, another question: has anybody gotten emacs 23.4-r2 to work in the BBB running Angstrom?

The one I have is 23.4.1.

Are you running ssh through cygwin? I’d suggest that but also don’t know if that would then also support the -X option. Also look for an option called “ForwareX11” that’s what the -X option activates in ssh.

  • RT

I am having the same problem with Emacs and the BBB… I’m running through Cygwin and I have used the -X option which connects just fine, but Emacs still does not recognize any keys…


I installed the Debian beta on my BBB and now Emacs is working fine…




Thanks. I would have installed Debian on my machine by now, but the 16GB Toshiba uSD I bought a couple of weeks ago has failed already. After the first couple of days, I had to reformat it repeatedly, both on the BBB and on each of two Windows (XP & 7) machines. Win32DiskImager didn’t work at all on the Windows 7 machine: it repeatedly hung as soon as I got to the writing phase in a way that required rebooting the Windows machine. I loaded and ran a disk imaging program from an outfit named RoadKil.net – that’s a sign of real desperation!. It got into the writing phase, but its progress stopped at 0.06%. At least it was possible to end that program without rebooting the machine.

I’ll try to load Debian again as soon as I get another uSD, and not a Toshiba this time.

  • R

P.S. Meanwhile, I’m using nano. Not emacs, but not vi, either.

Hi Frank,
Went out and bought a couple of 16GB SanDisk Ultra micro SD cards [the local Radio Shack was running a sale!], downloaded and installed Debian 7.3. Figured out how to install emacs (apt-get instead of opkg), and whoo-hoo, it now works.
Thanks for the suggestion.

  • Richard