eMMC Angstrom HDMI issue


I’ve been trying to get my Atrix lapdock working with the beaglebone and I’m having issues with Angstrom in particular.

I’ve downloaded and tested the 06-20 angstrom update and here is what happens:
When booted from my SD card, it gives me the beaglebone banner and then allows me to use the CL to login/use the board. My cable works perfectly I can use the command line.

After it has been flashed I boot up and get the beaglebone banner, however the signal from the HDMi port gets turned off and the screen goes dead. It doesn’t appear to be in sleep mode as my keyboard still works. I am able to SSH in and the page works as does cloud9.

Anyone have any ideas on how to fix this? I would prefer to use Angstrom to the alternatives so any help in getting the HDMI signal to not quit when booting from eMMC will be greatly appreciated!

Thanks for reading,

The latest image does not work on the Atrix Laptop. The timing settings in the kernel are incorrect.


Can you switch back to a text console with the latest image?

Hit <ctrl><alt><F1> on the BBB keyboard to go into console mode. If
that works, it's the custom Angstrom Gnome build setting the resolution
to something the monitor doesn't like. You can override this on the
Linux side, but I don't know of anyone yet who has worked out how to
coerce the Angstrom Gnome into a specific resolution.

It *MAY* help to pass a video= setting on the command line. When I was
trying to get my 7" 800x480 HDMI LCD working, Angstrom initially tried
talking to it like it was a full 720p display which made text virtually
unreadable. When I added video=HDMI-A-1:720x480@60 to the kernel
command line as described on my blog:


...the Angstrom Gnome install launched in the lower resolution and
things were *MUCH* easier to read. Note that in the Angstrom GUI, the
720x480 resolution was listed as one of the options, which means this
probably won't work if the resolution you want to use isn't in your EDID
already. For instance I was never able to get Angstrom running at the
native resolution of my panel, although I was able to get the kernel and
Xfce under Debian to use a custom resolution:


If none of the above helps and you really want to stick with Angstrom,
the two options I am currently aware of are:

* Figure out how to convince the Angstrom Gnome build to run at a
specified resolution

* Craft a custom EDID file to replace the one provided by your monitor,
and re-compile your kernel with CONFIG_DRM_LOAD_EDID_FIRMWARE enabled.

If you make progress on either of these fronts, please share with the group!


Console mode worked, however after attempting to edit the uEnv.txt and xorg.conf, I didn’t get anywhere.
I’m to try and hook up an older image and see what happens.