eMMC Backup fail


I’ve setup a debian on the:
BeagleBone Black rev 00C0 running BoneScript 0.2.4 at

with this image:

everything is fine! Now I want to backup my system and followed the:



I’m using a 16GB uSD, with one partition of 4048MB (tried both on windows and on debian with gparted ),
the only forder in the disk is “dtds” with inside the extracted content of the zip.


└── dtds
├── am335x-boneblack.dtb
├── autorun.sh
├── MLO
├── u-boot.img
├── uEnv.txt
└── uImage

but I’m unable to get it work, heartbeat LED won’t change, could someone please help me?

Thanks in advance! BR

More detail is needed.

Are there files on the eMMC that you need to preserve ?

Anyway, I see no instructions on the link you gave. Just a bunch of “posts” from some source about people talking about various things, perhaps some of it is related to your problem.

To make a proper backup in my own opinion. You need to use either dd, or tar. Then in the case of recent images, you’re going to have to use dd anyway to preserve the MBR ( Master Boot Record ) which contains the files MLO, and uboot.img.

Anyway, I need to know exactly what you’re situation is right now, and what you’re hoping to accomplish. Before proceeding further. But if you’ve wiped the eMMC already, and you’re “backup” is incomplete. Then there may be no other recourse than to start over fresh again . . .

And please forgive my improper grammar . . . a few of those you’re’s should be “your”. :wink: Multitasking here . . .

Thanks for your answer, I didn’t find any official documentation on how to make a backup…

But I’ve managed to make an img as backup with:

dd if=/dev/mmcblk1 | ssh user@targetserver 'dd of=sd-backup.img'

then restored on a uSD the system is able to run from SD.

I’ve tried to write the generated uSD on the eMMC by keeping down S2, then power, then release, without success.

Now I’ve booted up the system from uSD and launched this command, but it is running from an hour, I can see it in top

ssh user@targetserver 'dd if=sd-backup.img' | dd of=/dev/mmcblk1

Is this adviceable? are there other official ways to backup/restore eMMC with low timing? More than one hour for 4GB to be restored, seems to me too long.