eMMC broken?

I was working with some project, when suddenly I heard high-pitched sound coming from board. second after it turned of, and when I tried to restart I had only led 0,1,2 ON. there is no psychical damage visible on board. I downloaded latest angstrom image, writed onto microsd. Beagle is now booting (hooray!) but flashing is not qute working. I have external power adapter. I was trying to do this way:

1.power off
2. USER/BOOT button
3. power on
4. all 4 leds

after 1 min process, led USR3 (eMMC) flashes only few times, then i have normal heartbeat and cpu indicator. botting without microsd still results with led0,1,2 :frowning:
does it mean that eMMC is broken? i tried to read dmesg but i havent found anything useful. Any tips?

I have no way of knowing for sure. Maybe. Spontaneous combustion is something I have yet to run across on these boards.

If you can’t flash it, then maybe the eMMC is bad. Only way to know for sure is sending it in.


Thanks for your fast response. I was rather looking for some fsck-alike command (can i access eMMC while booted from microSD ?)
I would like not to send it now for 2 reasons

  1. its working from SD (for now)
  2. there is 99,98% chance that it was my bad :stuck_out_tongue: so i will lose 2 weeks or even a month and have to pay double-shipping

I thought about something different. After burning angstrom iso to sd card, I have 3 partitions
3,33GB, probably ext2 (not sure, i am on windows now)
26GB unallocated space

Can i use that space somehow, and just forget about eMMC ?

W dniu środa, 23 października 2013 02:08:29 UTC+2 użytkownik Gerald napisał:

You can forget the eMMC if you like.