eMMCnot enough space to do anything


I’m new to using BBB and the Linux environment. I have a BeagleBone Black Wireless board and managed to flash the eMMC with the “Debian 9.9 2019-08-03 4GB SD LXQT” following this link:


My problem is I have no space to do anything left as any commands I run to create files results in a error saying I have no space. Running df -h shows this as well.

debian@beaglebone:~$ df -h
Filesystem Size Used Avail Use% Mounted on
udev 215M 0 215M 0% /dev
tmpfs 49M 6.1M 43M 13% /run
/dev/mmcblk1p1 3.5G 3.3G 0 100% /
tmpfs 242M 0 242M 0% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 242M 0 242M 0% /sys/fs/cgroup
/dev/mmcblk0p1 30G 44M 28G 1% /media/Data
tmpfs 49M 0 49M 0% /run/user/1000

I have mounted an empty SD card with 32GB of space free to use, but still facing this problem of no space left. I tried to experiment with Cloud 9 IDE, but can use it as messages keep popping up about not have any space on the device.

My question is, what are my solutions to this? Is it better to just use the SD card instead of the eMMC to store the image? Is there away to use the external SD card to as the main storage and keep the image just on the eMMC?

I don’t understand the point of flashing the image to the eMMC if it doesn’t leave space for anything else.

I fixed this a week later, i don't have access to that server... Just
get the latest Stretch Snapshot: