Ethernet on BeagleBoard-xM rev C on linux kernel not working


I downloaded kernel from (2.6.32, same as
original) and trying to make ethernet work.
I used following configs:
- omap3_beagle_defconfig
- config taken from working linux from /proc/config.gz

Both haven't made my eth to work. And yes, I enabled usb eth gadget,
but I diffed mine and original kernel login and mine lacks with

usb 2-2.1: new high speed USB device using ehci-omap and address 3
usb 2-2.1: New USB device found, idVendor=0424, idProduct=ec00
usb 2-2.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
smsc95xx v1.0.4
usb0: register 'smsc95xx' at usb-ehci-omap.0-2.1, smsc95xx USB 2.0
Ethernet, ae:c0:34:8e:c3:64

Also! I have this driver compiled:
$ strings arch/arm/boot/Image | grep smsc95xx
<4>%s: MII is busy in smsc95xx_mdio_read
<4>%s: MII is busy in smsc95xx_mdio_write
<6>smsc95xx v1.0.4
<4>%s: Unable to allocate struct smsc95xx_priv
smsc95xx USB 2.0 Ethernet

So I ran out of ideas. Do you have any?

I tried vanilla kernel 3.2 with success

s/with/without :smiley:

smsc driver is in kernel but doesn't work