[EXTERNAL] Re: TI Follow Up Material - Beagleboard setup instructions

Hi Chris et al.,

Thanks for following up. I was able to begin the evaluation. There was a driver issue where windows (7) would not load the CDC serial driver. I could not follow the start procedure then as the pc could not communicate with the Beaglebone. I tried it on my Macbook Pro and was able to get it to work. I did perform the update and wrote the update FW to the eMMC. This resolved many of the issues. The serial driver still does not load properly on windows (7) but I was able to run the getting started steps. I followed the advice and tried on a windows 10 pc. While it did work there is still a message that drivers were not loaded (CDC ECM). The elements on the (Beaglebone 101) page do work. My next step was to try and attach the BBONE-GATEWAY-CAPE. Following the steps in the Readme I have not been able to get that up and running. First problem is the root password. This is not accepted - says access denied. I was able to get in by SSH/PuTTY and used the username Debian and password temppwd. I tried setting a root password with sudo but after a restart root still won’t work - not sure that is a problem since I can proceed with the Debian username. It would be nice if the documentation reflected the actual experience.

What exactly needs to be done to enable the wireless cape. The readme instructions are either not correct or not enough explanation for me to make the changes needed to enable it. Perhaps I am not as versed in what needs to be done and it is an insufficiency on my part.

The uEnv.txt from the /boot and the latest firmware is:

Hi Fred,

This Gateway Cape is extra special. It’s eeprom is blank, it was designed without following our cape spec, so it’s basically impossible to detect on bootup… Then they added random jumpers to change other connections… So yeah pain in the…




in /boot/uEnv.txt

If you change any jumpers, make sure to us the source under /opt/source/bb.org-overlays/ to update BB-GATEWAY-WL1837-00A0.dtbo…

Yes, the Windows 7’s “built-in” serial driver doesn’t work… Micosoft added this “built-in” serial driver in Windows 8, and didn’t back port to Windows 7. Windows 7 only has one more year left in “extended support” and I do not have any Windows 7 (nor Windows 8 machines to test…)

Yes root was removed from ssh, as a few BeagleBoard Blacks ended up in bot nets…


Hello Fred,

Jason and I have communicated together on this and it appears based on the below logs that the exact steps (offered in Robert Nelson’s instructions) here are perhaps not being followed exactly.

Using the exact image and specific instructions provided with the cape should help. Jason may be able to provide an even more updated image as well, in the event you are still having issues with running the image you currently have.

You should have received, along with the cape, instructions such as these attached.

Lastly, I’d like the opportunity to introduce one of our TI 3rd party developers, Vanteon Corp, who has extensive knowledge of these chipsets and development eco-systems. Vanteon has even created their own vGateway reference design using many of the same TI devices you are evaluating, which can be scaled up or down to meet the specific demands of a user’s design. This platform supports WiFi, Zigbee, BT, cellular, sub-GHz among other standards along with the TI Sitara AM335x Host processor (same as Beaglebone). We’d invite you to learn more.

Please let us know your thoughts and thanks again for your interest in TI.

Chris & Team

2092456.pdf (415 KB)

I would encourage you to try the exact steps as written yourself. Not as you may know how to make it work, but as written in the various start up and readme instructions. This is what I am trying to follow. Also read the comments below the readme in the website for setting up the cape. There are others that are seeing similar problems. (https://www.element14.com/community/docs/DOC-83730/l/bbone-gateway-capereadme11292016v0-1pdf)

Partnering with Vanteon to develop this product is not an option. We have the suitable team that will develop the necessary code once we have selected the hardware platform. There are two others in consideration. Both are using I.MX based solutions. One is at the level we desire to proceed. If we can get to a similar stage with this hardware, it can still be an option to select. The I.MX was set up and controlling a remote Zigbee device (included with the evaluation kit) and also being cloud connected.

Following the first several steps of the readme I got the latest image. I created an SD that reflects this upon normal bootup. I have tried it with the Gui and Non-Gui versions. I can successfully launch an SSH connection to the BB board. User name of root with no password is not accepted. I have discovered the proper credentials that will allow it but they are not mentioned anywhere in any set of instructions. The posted image of the contents of the uEnv.txt were prior to any edits. That is what is in the boot folder from the image of the latest FW download.

Here is the attempted SSH login as per the readme doc

login as: root

root@’s password:

Access denied

Logging in using the Debian user name and temppwd lets me in with sudo level permissions.

Here is the contents of the fresh FW image of the uEnv.txt file:

login as: debian

debian@’s password:

The programs included with the Debian GNU/Linux system are free software;

the exact distribution terms for each program are described in the

individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent

permitted by applicable law.

debian@beaglebone:~$ cat /boot/uEnv.txt

#Docs: http://elinux.org/Beagleboard:U-boot_partitioning_layout_2.0




###U-Boot Overlays###

###Documentation: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#U-Boot_Overlays

###Master Enable



Thanks Fred. Appreciate your additional comments. As you may or may not be aware, there were some design trade-offs on this particular cape that resulted in it not being granted 100% BeagleBoard.org support, but I understand that we have it working with recent images. I’ll ask Jason and his team to reply.

Jason/Beagleboard Support: Please indeed find the additional comments from our customer below. Any concise guidance that can be provided to address Fred’s inquiry would be much appreciated. We just need to get through the start-up/configuration process so he can continue with his TI evaluation.

Best to all,


Hey Jason – FYI some additional information from the customer. Would really appreciate any pointers you can offer.



Also, any way to loop in Robert Nelson directly, given it appears they are trying to follow his instructions?

This previous e2e forum post has the same basic question on the same cape:


Any help welcomed and appreciated.

Thanks Jason,


Also, any way to loop in Robert Nelson directly, given it appears they are trying to follow his instructions?

This previous e2e forum post has the same basic question on the same cape:


Any help welcomed and appreciated.

Thanks Jason,