Fail to boot from SD card with Ubuntu 22.04 image - 3 LED glowing solid - No error on HDMI/UART

Hello all,
Working on a Beagleplay board to install Ubuntu 22.04 I found from the following location:

I flashed the SD card with one of the image for Beagleplay ubuntu - but on booting from the SD card, I’m getting no HDMI signal or the UART is not up as well. THREE LED LIGHTS ARE GLOWING STRONG WITHOUT BLINKING.

Here are the things that I tried:

  • Use two SD cards, one of them was brand new. Tried to reformat them and flash with the image.
  • Used Baleno etcher, Rufus to flash the cards.
  • Used the power on sequences > 1. Press usr button, power up, release usr button AND 2. Press both usr and reset button, power up, release reset button, release usr button.
  • Kept the device in this state for 10min, 1 hour, over night, the state does not change.

In all the above cases

  1. I’m not getting any error log or signal on HDMI
  2. Not getting any error on the UART.
  3. Not getting (not sure) boot menu (if its supposed to come on its own)

Although booting from the eMMC to the default OS Debian is smooth and everything works just fine.

Please suggest how do I debug this. What am I doing wrong here?


Please post a link to the exact image you are trying to load so we are all on the same page.

Hello foxsquirrel, Thanks for responding

I have tried the following images, (both with beagleplay in the filename - img.bz2 and img.xz)

I will look at those this evening and see what is up.
Also, best way to burn the SD card is to use the raspberry pi imager, it verifies what was laid down on the card.

Sorry, I don’t have a solution for you. Mine would not boot from SD so I had to erase some of the emmc to force it. Did get it to finally attempt to boot from SD, that image might need some work.

Here is what I did get,

U-Boot SPL 2024.04-g881379e9 (Apr 06 2024 - 19:48:55 +0000)
SYSFW ABI: 3.1 (firmware rev 0x0009 '9.2.7--v09.02.07 (Kool Koala)')
SPL initial stack usage: 13384 bytes
Trying to boot from MMC2
Starting ATF on ARM64 core...

NOTICE:  BL31: v2.10.0(release):753da8c
NOTICE:  BL31: Built : 19:48:55, Apr  6 2024
I/TC: OP-TEE version: 4.1.0 (gcc version 11.2.0 (Ubuntu 11.2.0-19ubuntu1)) #1 Sat Apr  6 19:48:55 UTC 2024 aarch64
I/TC: WARNING: This OP-TEE configuration might be insecure!
I/TC: WARNING: Please check
I/TC: Primary CPU initializing
I/TC: GIC redistributor base address not provided
I/TC: Assuming default GIC group status and modifier
I/TC: SYSFW ABI: 3.1 (firmware rev 0x0009 '9.2.7--v09.02.07 (Kool Koala)')
I/TC: HUK Initialized
I/TC: Primary CPU switching to normal world boot

U-Boot SPL 2024.04-g881379e9 (Apr 06 2024 - 19:48:55 +0000)
SYSFW ABI: 3.1 (firmware rev 0x0009 '9.2.7--v09.02.07 (Kool Koala)')
SPL initial stack usage: 1888 bytes
Trying to boot from MMC2

U-Boot 2024.04-g881379e9 (Apr 06 2024 - 19:48:55 +0000)

SoC:   AM62X SR1.0 GP
Model: BeaglePlay
DRAM:  2 GiB
Core:  98 devices, 27 uclasses, devicetree: separate
MMC:   mmc@fa10000: 0, mmc@fa00000: 1, mmc@fa20000: 2
Loading Environment from nowhere... OK
In:    serial@2800000
Out:   serial@2800000
Err:   serial@2800000
Net:   No ethernet found.

Press SPACE to abort autoboot in 2 seconds
switch to partitions #0, OK
mmc1 is current device
SD/MMC found on device 1
Failed to load 'uEnv.txt'
Scanning for bootflows in all bootdevs
Seq  Method       State   Uclass    Part  Name                      Filename
---  -----------  ------  --------  ----  ------------------------  ----------------
Scanning bootdev 'mmc@fa00000.bootdev':
Scanning bootdev 'mmc@fa10000.bootdev':
No more bootdevs
---  -----------  ------  --------  ----  ------------------------  ----------------
(0 bootflows, 0 valid)

That is from the ubuntu image from the link. The board had a desktop environment installed and it would never boot from sd. That might be why the board is at home and not at work anymore. Hopefully some one else in the community might be able to get you up and running, sorry.


I looked in our archive and found this image, it does install itself and ifconfig shows networking is active. Not sure where the original download link is. If you can find that this image it should boot and install on your board. Did notice it kills the debug port in post u-boot so you will need an hdmi monitor. If the lights are strobing across it is dd’n to the emmc, it takes a while. When it shuts down remove the SD and power cycle.

1 Like

hello everyone

I tried to boot the latest Ubuntu image from the following location, and found the issue still persists on my beagleplay.


This time, I used the Raspberry Pi imager AND Balena Etcher to flash the SD card.

Curious if these images are CI builds or manually tested / shared by somebody? Would really appreciate a way to debug this or a good image.


They are weekly ci builds, ubuntu on armhf/arm64 gets zero testing…

Which version of etcher, there are known broken ones…

You can also use bmaptool:

sudo bmaptool copy beagleplay-ubuntu-22.04.3-console-arm64-2024-05-22-4gb.img /dev/sde

Please share what you do see over the serial debug.


Hello Robert
The etcher I was using is 1.18.11.

I also used the bmaptool to copy the img file to the sd card.
The device is still behaving in the same way. 3 LEDs glow strong, there is no signal to UART, no logs.