Failure to re-flash Beagle Bone Black


I have a Beagle Bone Black (BBB) that I somehow managed to brick and I have been following the instructions on these two sites to try and re-flash the image:

I am using a Windows 64-bit PC to connect to the BBB and I am using the image titled “BBB-eMMC-flasher-2013.09.04.img.xz” which I downloaded from here:

I have tried multiple times to re-flash my BBB but so far nothing seems to work. I am following the directions which are to 1) put image on sdcard, 2) put sdcard in slot, 3) hold down user boot button, and 4) turn on BBB by plugging in a 5V power brick, 5) release user boot button when all 4 LEDs are on. Every time I do this, I told the user boot button down until all 4 LEDs light up solid and then start flashing, at which point I release the button. I wait 45-60+ minutes (one time I let it go overnight) but at no point do I end up with an indication that the re-flash is complete (i.e. all 4 LEDs lit up solid). During the re-flash process (or what I assume is the re-flash process), the LED’s look like this:
LED 0 - heartbeat, which indicates system is running
LED 1 - Nothing. This corresponds to access of the microSD card
LED 2 - Blinking. This corresponds to an active CPU.
LED 3 - Nothing. This corresponds to access of on-board memory

I have tried plugging in an HDMI cable so that I can view what is happening during the re-flashing process. Upon bootup, the monitor shows a BeagleBone flash screen followed by a login screen. By using a USB-connected keyboard I can log in as “root”. It does not ask for my password even though I had created a password for my pre-bricked BBB. Once logged in I can navigate through different directories, manually turn on/off LEDs, etc. Note that the login screen only appears if I have an sdcard in the BBB. Without the sdcard, the BBB will have the power LED on, but will not respond, nor will it connect to PC, nor will any of the other LEDs come on. Also note that it does not appear to matter if I press the user boot button or not… the BBB seems to always boot from the sdcard if it is plugged in.

I’m at the point where I am about ready to throw away this BBB and buy another. However, I would prefer to solve this mystery if possible. Any suggestions would be most welcome. If you have any follow-up questions I’d be happy to answer them.


Are you unzipping the image that you download?
Make sure nothing else is plugged in, no HDMI and no Ethernet.
Make sure 5V power supply can deliver at least 1A.
Reformat the uSD card before you use Windisk to copy the image onto the 4GB card.


Thank you for your reply. To answer your questions:

  • Yes, I am unzipping the image that was loaded prior to putting it on sdcard
  • Nothing else is plugged in. Only SDcard and 5V brick are plugged in
  • The brick is rated at 5V, 2Amps
  • I have formatted the SDcard but not consistently. I will try again.

Note: The SDcard I am using is a SanDisk 8 GB class 4 card. It has been used successfully to re-flash (un-brick) a different BBB, although I am using a different image.

Create a uSD card that successfully flashes the other board again.
Then try it on this board…
If it fails, then request an RMA and we can look at to to see what is going on.


This is the best way I found to be sure that your card is completely clean before reflashing:
Run in command line as administrator-

  1. Diskpart
  2. List Disk
  3. Select Disk 1 (Replace 1 with number reflecting your SD Card)
  4. clean
  5. create partition primary
  6. active
  7. format fs=fat32 quick
  8. assign

I use dd command in linux to make cards but if I do not run these commands on my windows box my cards never seem to work.

I am in the same boat. In my case, I was following the instructions on the Adafruit site for installing a driver that works with their WiFi USB dongle. I was ssh’d into the BBB via ethernet and the power was from a 2A USB power brick. (So no access via the USB port.) The instructions reach the point of inserting the WiFI dongle, then rebooting. When it rebooted, I could not get in via ssh over the ethernet and had no other access to the board. I eventually bailed and pulled the power. I then move over to my bench with a HDMI monitor/keyboard/mouse and booted up there. At that point, the BBB booted, but got stuck at a screen selecting a choice of logins (which I can’t remember at the moment) + “other”. That last option would allow root for the name, but when I attempted to “skip” the password prompt, it just indicated that authorization failed. Same reaction for the two other names I could log into. In past experience, this usually means the password files have been corrupted. So, I am starting the reflash process. Unfortunately, I get the same thing, it wants to boot to a login prompt and does not enter the flash phase. I am going to completely reformat the SD card (a 16GB Sandisk Ultra class 10), then copy the image again.

If this does not work, I will just install the Cloud9 image on the SD card and boot off of that.

I have successfully reflashed the OS. The thing I did wrong was having anything other than power plugged into the board. I am guessing that the boot code checks for USB keyboard/mouse and/or HDMI and boots to the OS if present. I also know that you can’t plug anything in once the flash write process starts … if you do, the flash will fail. Finally, once the flash write finishes and all the LED light up, I powered off, ejected the uSD, connected the K/V/M and repowered. It did nothing until I pressed the reset button. Now it is all good.

I also looked more closely at the Adafruit instructions and they do indicate that these were for the white Beaglebone and may not work on the BBB. (They don’t!) I am going to give Ubuntu a shot and see if I can find a functional WiFi driver for the dongle I already have. Otherwise, I will have to hit the buy button on something in the “known good” list of WiFi options.

Thanks for your patience with me!